RC signals disapeared


I am facing a problem that has just appeared. My RC signals are not being detected, even though they worked originally. I’ve rebooted my Cube Orange, reset the default parameters, deleted Mission Planner and QGC, reinstalled them, but nothing has changed. I don’t know where the problem is.

I also changed my RC receiver and transmitter, but the same problem persists.

Does anybody have any idea how to help me, please?

Thank you.

I assume rebinding was part of swapping Tx and Rx.

What Tx do you use?
What Rx do you use?
What protocol do you use for RC?
Where is the Rx connected to the FC?

It would probably also help to share a .param file with your parameters.

I have an R8EF and a radiolink T8S.
For the protocol, I have put 1 on mission planner to allows all types of protocols ( I don’t know what kind of answer you want :confused: )
I have linked the Sbus signal from my Rx to the RCIN of the cubeorange.

Here the .param you asked :
version1.param (14.0 KB)

Thank you.

“Sbus” is the protocol i meant :wink:

I would probably account this problem to hardware, either loss of bind between Tx and RX, a bad connection to the cube or something with the power supply of the Rx…
But I wouldn’t consider myself an expert in this matter.

I’ve changed the Rx and the Tx but it doesn’t work neither…

Thank you for the time spent trying to help me :wink:

I think that the problem is when I try to update firmware ardupilot to firmware Px4 ?

If you have done that you are now in the wrong forum. Go here PX4
Or, flash back to Ardupilot.

I am also trying it on ardupilot, but the problem come when I change from ardupilot to px4

So pick one and use the right forum. Also, this looks like a Rover parameter file and you are posting in Copter (fixed it).

There is something seriously wrong showing in that parameter file. If you are going to stick with Ardurover (it’s a rover right?) re-flash the Ardurover firmware, reset to default and post a screen shot like this from Mission planner:


My RC is now working in ardupilot, but I don’t receive throttle output signals, and I have a lot of “failsafe warning” when disarmed, would you be able to help me for this problem?

Post the warnings you are seeing from Mission Planners messages screen.

Here screenshots of my Mission Planner screen :

None of these pictures shows the messages screen and none of them shows the failsafe warnings you were talking about earlier.

We can help you if you don’t tell us which warnings you get.

sorry ,

Those are all prearm warnings, not failsafe warnings.

Do you have a hardware safety switch on your drone?
If yes, the warning should go away when you press it.
If not, set BRD_SAFETY_DEFLT = 0

I don’t have a hardware safety switch, so I set BRD_SAFETY_DEFLT = 0, but always exactly the same message…

when I armed, this appears :