RC failsafe won't work

I set RC failsafe on my RC controller (Futaba T8J) to terminate the flight when the connection is lost. however, the PWM value won’t change. How can I fix it? I use SBUS and connect the receiver(R2008SB) and FC(pixracer). RC safety is disabled.

You need to configure the failsafe on your transmitter (actually it configures the receiver, but the settings are on the transmitter’s options menu). You need to set it to a PWM value that normally your transmitter could not produce (trim the throttle to the absolute minimum level), then set the failsafe on your transmitter with zero throttle (trimmed). Go back to your flight controller and observe the CH3 input pwm value (should be less than 1000, for example 900). Then set FS_THR_ENABLE to a desired action and FS_THR_VALUE that is a little bit more than the trimmed throttle value. For example, if trimmed throttle is 900, then you can set it to 920. This procedure enables the throttle failsafe behavior of autopilot. BTW, you should take a look at the wiki.

Thank you for your reply! I tried doing that but the pwm value won’t change… what I want to do is to stop motors when the connection is lost. So there is no options for that

it sounds like you have it set to hold mode.

Have you checked this post yet? How to power off motors when RC failsafe is triggered - #9 by bigboy061293

I guess you can find the answer.

because you failed to set failsafe on you transmitter. Take a look at some tutorials or videos about your exact transmitter.

You want to kill the motors immediately, even on air, am I right?

Yes, you are right. because it’s the rule of the competition. I have tested the receiver and noticed that pwm channels are changed to failsafe value, but pwm values on GC don’t change (The connection between FC and receiver is sbus protocol).

Got it. Take a look at this. You can set an AUX switch as one of the Emergency Stop Motors, Motor Interlock, or Brake that suits most to competition requirements.

But it should.
Probably there is an extra option in the transmitter.
I don’t have a knowledge of that particular transmitter but in T14SG, I am working with SBUS it works as it should without any change on autopilot side.