Servers by jDrones

RC calibration Problem

arducopter
mission-planner
ardupilot
missionplanner

(Benyoucef) #1

Hey, I tried to do a Radio calibration but I’m facing a problem. I followed the tutorial here but when i tried to move the control sticks and toggle switches on the transmitter to their limits of travel, the bars don’t seem to move. Can anyone tell me what might be the problem.
I am using Navio+ and Raspberry Pi2 as an autopilot to control a quadcopter.
I have a question should we pick airplane mode regardless of the platform type being piloted like in APMplanner?.
Thanks


Radio control is not active or turned on Problem
(Mike Boland) #2

Some more detail of your setup would help.

What Tx and Rx are you using?
What flight controller?
How have you got them wired?
What version of Mission Planner?
What version of firmware?

It will help people to give you some meaningful answers.

And yes, airplane mode is the way to go.
The flight controller does all the translations.


(Benyoucef) #3

Thanks for the reply, I didn’t get a notification for that.
For Tx and Rx I’m using FlySky
For flight controller, I’m using Navio and Raspberry Pi with emlid Image that has Ardupilot pre-installed
And yeah I got them wired up here

I’m using Mission Planner 1.3.48
For the firmware, it is Arducopter 3.4.6
you said that we should do the airplane mode, well that wasn’t mentioned. Please, can you give the chronological steps! Thanks