Radio control is not active or turned on Problem

I am in the process of controlling my drone with navio+ and Raspberry pi as an autopilot with flysky radio transmitter receiver. I have managed to connect with APM Planner with the drone, everything is settled but when i hit calibrate button an error pops up telling me Radio control is not active or turned on . attached you can find the log file, Please any suggestion will be appreciated, Thanx.

apmlog_20170609.txt (514.4 KB)

According to your log it seems like the APM Planner can not fetch the Parameters anymore which leads to this behaviour. Perhaps I can find out why

I think you are right because i tried it with Mission planner, I could connect it but it keeps saying getting parames and it never ends. Have you any idea how to solve it. Thank you

Which ArduPilot Version are you using? 3.6-dev?

The Problem seems to be ardupilot related. I hope I can do some further investigations today or tomorrow

I install it from here. please keep in touch. Thank you

Sorry I tried to reproduce your issue this evening but on my environment every thing works as expected. To be fair I could only test against a simulated Arducopter.

Thanks for trying. I will get another Navio card and try again and I will tell you what i got maybe the current Navio i have has some defects.

Hi, I just wanted to know if that has anything to do with the IMU (I mean sending PPM signals and get the motors running) Because something is wrong with the IMU chip. I’ll be getting another one after two weeks from now.

hey again, i tried to calibrate the the Radio but still no luck here attached you can find the txt file, please take a look and tell me what i did wrong because i could connect the autopilot with APMplanner but this latter is not interacting or showing data. Thank you in advance
apmlog_20170704.txt (429.3 KB)

Hi - I can not download the logfile. If your Problem still persists it would be nice if you could upload the logfile again - I will have a look than.

Thanks a lot, Now I am facing another problem That I posted here I will be so thankful if you can help me with that.
Now I am working with mission planner. I think it is easier when doing RC calibration
PLZ take a look at it

I am facing the same problem with arducopter-3.5 on beaglebone blue.
I am using the Flysky RC radio.
Please suggest if you have found the solution.