Rather than showing map and MAVProxy console it directs to XTerm Console

Dear, I am running SITL Ardu Pilot, installed everything as mentioned by with in the tutorial.
When i run command
sim_vehicle.sh -j4 --map --console --aircraft test

It just only show the command line interface and XTerm showing the status of flight, i am expecting map and other console showing all the details like parameters.
Is there anything else to do to enable maps…?

This is the error i am getting when i run the sim_vehicle.sh --map --console command

WARNING: You should uninstall ModemManager as it conflicts with APM and Pixhawk
Connect tcp: source_system=255
Process Process-1:
Traceback (most recent call last):
File “/usr/lib/python2.7/multiprocessing/process.py”, line 258, in _bootstrap
File “/usr/lib/python2.7/multiprocessing/process.py”, line 114, in run
self._target(*self._args, **self._kwargs)
File “/usr/local/lib/python2.7/dist-packages/MAVProxy/modules/lib/wxconsole.py”, line 37, in child_task
from wx_loader import wx
File “/usr/local/lib/python2.7/dist-packages/MAVProxy/modules/lib/wx_loader.py”, line 9, in
import wx
ImportError: No module named wx
Loaded module console
Loaded module map
no script test/mavinit.scr

Have you solved the problem yet ?