Raspberry pi and pixhawk wont communicate each other

I have this problem communicating with my raspberry pi and pixhawk.
with this error
“pi@raspberrypi:~ $ mavproxy.py --master=/dev/ttyAMA0 --baudrate 921600 --aircraft MyCopter
Connect /dev/ttyAMA0 source_system=255
no script MyCopter/mavinit.scr
Log Directory: MyCopter/logs/2021-08-02/flight10
Telemetry log: MyCopter/logs/2021-08-02/flight10/flight.tlog
Waiting for heartbeat from /dev/ttyAMA0”

i also enable, “enable_uart=1” and disable “dtoverlay=dsibale-bt” in my “sudo nano /boot/config.txt”
i thought im full set but it didnt work to communicate sad.

so manage to execute this “mavproxy.py” command line and i notice my /dev/tty" is ttyS0 whenever i execute it i also got the same error message before.

407parammm.param (18.1 KB)

This are my params and screenshot.

The I/O message suggests the wiring is not correct? But assuming you have installed the software and wired the boards together correctly, what happens if you try a slower baud rate (eg, 57600)?

the wirings are correct but i switch the rx to tx and it work but ive noticed whenever i switch flight mode it wont change and it only stuck in stabalize mode. image

whenever I try a slower baud rate it won’t connect me it always looking for a heartbeat.

whenever i switch to default wiring without changing this what im getting the connections are secured.

I assume you followed this?


All four wires are going to TELECOM2 ?
I ask about the baud rate because when I enter the higher rate it also fails.

I am running several RPi/Pixhawk vehicles. Here is some output from one. I don’t run root, I don’t understand why the above link shows this.

yes, I follow this instruction but still haven’t fix yet. my baud rate “921600” so whenever i enter the higher baud rate it wouldn’t connect so i will go on lower baud rate let me test it later i hope it works.


so i need to lower the baudrate because my value back then was 921600 now im changing it into 57600 i hope it works.

i follow the lowest baud rate doesnt do anything.

I’m sorry it is not working for you. Perhaps another reader can contribute. Another resource to consider is https://dojofordrones.com/. Caleb walks you through the entire hardware and software builds for the RPi to Pixhawk configuration.

i watched his content pretty helpful for my project but i dont know what when ever i implement to my devices it doesnt work now im stuck here with this communicating with the two devices.

“…but i switch the rx to tx and it work but ive noticed whenever i switch flight mode it wont change…”

This indicates you had the wiring crossed, so keep it that way. The fact it is not switching modes is a software issue. I would suggest starting over and reinstalling the software, checking your Mission Planner settings. I have done this often in the past and it helped because I missed a dependency or such.

its really weird it should be working properly but when we follow the instruction our device goes nuts hmmmm

what software did you use to work perfectly.

I am referring to the Raspberry Pi software in Caleb’s course.

i also follow that but it didnt work as is used to be some say the firmware is the problem i think i need to degrade.

I suggest you start easy = use a FTDI usb to serial adaptor and do a terminal to terminal test between RPI and a PC then , once the communication link is proven working it will be much easier to work on Mavlink

1 Like

what is an FTDI, thank you for your suggestion sir i hope it helps my problem here.

i bought myself a USB to TTL it didn’t work as i wanted to be still having a problem