Servers by jDrones

Raspberry 4-cube orange-not take off in guided mode

Hi everyone, I started building an hexacopter (flame f550) using a raspberry 4 and the orange cube with optical flow and a leddar One. I have installed mavros. I’m trying to get the raspberry to communicate with the cube. I can see the topics and read what they publish. But I have these problems:

  1. At the beginning i couldn 't see the eco of the topics so i use this line “rosservice call /mavros/set_stream_rate 0 10 1”( is it correct?)
    but i can’t see the eco of local_position/pose. Do you know why or how i could solve this problem?
  2. my second problem is that the copter could not take off. I switched the mode in guided and arm the copter then I tried to publish a velocity with “mavros/setpoint_velocity/cmd_vel_unstamped” but the copter didn’t listen to me. So i tried to use “mavros/setpoint_position/local” but nothing. i think that for now i can’t use setpoint_position because i don’t have an echo from local position.
    My question is :
    what am I doing wrong?
    I attached mavros diagnostic, checkid and my simple code ( here i used mavros/setpoint_velocity/cmd_vel_unstamped) . if you need i can attached the ardupilot parameters.drone_velocita_takeoffland_LEDDAR.cpp (6.8 KB) diagnostic_checkid.txt (5.5 KB)
Servers by jDrones