Servers by jDrones

Rangefinder for object avoidance


(Javier Beringola) #1

Hi, just a suggestion. The link

http://ardupilot.org/copter/docs/common-rangefinder-objectavoidance.html#common-rangefinder-objectavoidance

says:

Connecting and Configuring the Lidar

follow the normal instructions for setting up rangefinders.
set the RNGFNDx_ORIENT parameters (i.e. RNGFND_ORIENT, RNGFND2_ORIENT) to specify the direction the range finder is pointing in (i.e. 0=Forward, 2=Right, 4=Back, 6=Left, 24=Up, 25=Down)
set PRX_TYPE = “4” to enable using range finders as “proximity sensors”.
set AVOID_ENABLE to “7” to enable avoidance using proximity sensors (and fences)

Rngfnd_orient only works for downwards with leddarone.

Prx_type works perfect with 0(none) with leddarone. Option 4 will say lidar unhealthy or check proximity sensor

Avoid_enable to 7 is not possible in ac 3.5.3. Only 3 (all) is possible.

Thanks in advance


(Vitaliy) #2

Good day. Installed firmware 3.6.2. It all worked


(Javier Beringola) #3

Thanks.

Looking forward to install it


(Vitaliy) #4

https://discuss.ardupilot.org/t/connection-2-pieces-leddarone-problem/35455

I had the same problem. I installed 3.6.2. it all worked right away.