Rangefinder data very erratic on Cube Orange, not on Cube Black

Hello all,
I had my Octocopter dialed in on a cube black and had a failure of the GPS connector separating from the carrier board. I believe I can fix it, but took the opportunity to replace the entire carrier board with my Cube orange. Both running on Copter 4.1.5. I have a Garmin Lidar Lite facing down for an altimeter and has been flawless. Here is a quick video showing the holding.

Now I have imported the parameters and made some adjustments to get the dual Here 3 GPS’s working on the cube orange. I noticed the rangefinder data jumping around a bunch. I did not have this problem on the cube black. I did move some wiring around and loomed all of the wiring in PET wire looming. I changed the logging to save logs when disarmed and verified the data on the hud matches the logs. I wanted to check for interference and unplugged everything one by one to see if the data would get steady and it did not. I unplugged the cube orange and set the cube black back up and it is reading the normal reading. I mad a quick video on it here.

Garmin Lidar Lite on Cube Orange - YouTube Cube orange data variance

Garmin Lidar Lite V3 on cube black - YouTube Cube Black Data Normal

The Garmin is on the I2C and is the lone connection on it. I have it on a multiport board but plugged into the carrier board it is the same. Power is powered on a 5V BEC that has good filtering. My Oscilloscope is down so I cannot look at the signal wire from the Garmin to check the data voltages over time domain. Anyone have any ideas?

I want to get this thing airborne again.


ETA: I tried to upload a log from the Orange Cube but it says the file is too large.

use something like wetransfer.com

Here is the log file. By the way, the filtering may be off, I tried a bunch of filter options in the off chance that would at least work. I have also done a parameter comparison between the cube black and cube orange. Besides the read-only parameters, all the settings are correct.

Another update, I plugged the Cube Black into the ADSB carrier board and the rangefinder data is good. I am wondering if I have a bad Orange cube?

I am bumping this since others seem to be having issues with the cube orange as well. I do not want hijack someone else’s thread. Anyone have any idea’s?

Cube black works fine. This is regardless of ground type and distance.