Radiolink Mini-PIX copter 3.6.3 ChibiOS = No IO Thread Heartbeat / PreArm

After reading about the benefits of ChibiOS, I flashed my daughter’s quad with a (then working) Radiolink Mini-PIX flight controller to the latest ChibiOS based Arducopter 3.6.3 firmware through the regular Mission Planner. (Previous to this I had only used the Radiolink branded Mission Planner.) After reading several threads on various forums, I realize this flight controller is not a “true” Pixhawk, but does seem to work most of the time, and it always worked well on the old Radiolink branded firmware.

It goes through the whole wizard fine in the regular version of Mission Planner with the new firmware, and everything seems to be OK except the quad won’t arm anymore. This is the error we’re getting now:

No IO Thread Heartbeat ()
PreArm: Logging failed
Frame: QUAD
mini-pix 00280026 3436510A 35393336
ChibiOS: ff603d11
ArduCopter V3.6.3 (63eb66fe)

It seems to be a logging problem - either it’s trying to put a log file somewhere that doesn’t exist or something like that. This flight controller has no SD card that I know of, though it may have a small flash area for storing a log? Does anyone know some steps I can try to fix this logging error to get it to arm again?
I also tried reverting it back to the old Radiolink branded firmware through their own mission planner version, but it looks like that won’t work now that we’ve gone from the Nuttx OS to ChibiOS.
Thank you for any help!

Turn off the the logging arming check in ARMING_CHECK bitmask, if you get the latest mission planner (posibly the beta) you can double click on the param in the full list and it will bring up a ticky box for the bitmask

untick all and tick everything else except LoggingAvailable

Hi, the same thing happened to me,

can not write to microsd.
It’s from the micro SD card, I found a micro SD 2GB and it works for me.

I do not know the specifications


Seems formatting the SDcard to FAT instead of FAT32 clears the problem… Worked on two Pixhawk boards to fix this problem for me.



Tridge is working on the SD card issue and I suspect we will have a fix in Copter-3.6.5. Until then you may want to try Copter-3.6.4 to see if it helps.

You may also find that the NuttX version of 3.6.4 works. When the MP pops up a message, “Load ChibiOS?” reply, “No” and then the NuttX version should be loaded.

Thanks for the fast help! We just got back home from Christmas holidays with the relatives, so I will try the suggestions tomorrow and report back with any results. If it helps, I don’t think this little Mini-PIX has a removable SD card slot like the full Pixhawk does - so is it trying to store the log file in an on board flash storage of some sort?

@DrPop you’ll find the SD slot below the Telem2 connector:

cheers, basti.

Thanks! I feel like an idiot now, I never even realized this thing even had a micro SD card slot! I guess the original Radiolink branded firmware never gave me the option to log (or at least didn’t give the logging error), so when I upgraded to the new “full” Pixhawk firmware with ChibiOS, it errored out because I didn’t have an SD card in there.

For anyone that has this problem in the future: Did as recommended above, found an old 2GB micro SD card, formatted it FAT, and it works! I don’t have the props on it yet, I’ll take my daughter out to fly it tomorrow, but this is the first time it armed with the new firmware & ChibiOS.

Thank you to all the Arducopter programmers - you have made this little flight controller even more of an incredible value!