Radio Calibration says my radio is not active or turned off

I’m trying to set up a quad with Megapirate firmware. Here is what I have:

HK AIOP board
Futaba 8 channel receiver
APM Planner V2.0.16 under Windows 7
APM-Copter-Quad Ver 3.1.5-R2
So far everything loads and runs
Compass Calibrated
Accel Calibrated
GPS locked in with 10 sats and a 3D fix
Flight modes can be set and respond to the flight mode switch
Failsafe can be set
All of the bars move as expected in the Radio Calibration screen

Now the problem, When I hit the “Calibrate” button I get a popup with the following message:

"Radio Control is not active or turned on"

Any clue as to what I have missed here?

Just an update.

Looks like the problem is in the APM Planner 2 somewhere.

I tried Mission Planner Ver 1.3.21 and was able to do the radio calibration with no problem


Same problem here with spektrum and pixhawk.
Did it also with mission planner.

I have just tested this on my Taranis with FrSky D4r-II receiver and it works as expected.

If i plug in the receiver and no signals are coming from it, it won’t allow calibration, only when the green bars appear in the calibration window will you be able to calibrate.

Are you seeing valid RC Signals?

Screenshot one, no signal from RC = error
Screenshot two, valid signals = OK

PS: I did notice that it checks for all 8 channels, are you using less, are you using PPM SUM or just PWM?

Maybe that the issue. You can check using the the failsafe page as it shows all the channels by number


Ok, thats the problem. I did not have channel 8 connected. With one more wire added the calibration works. Maybe a better error message would be appropriate. Is there a way to tell the program how many channels are actually in use?


I only have a 6-Channel receiver, see the signals on my screenshot attached.
But I’m still not able to calibrate it.


What about on the failsafe page? Can you post a screenshot?

Here is the screenshot of failsave.

That’s great. 7 and 8 are zero which causes the error. I’ll fix the logic to check for valid radio signals

Sounds good, I’m then waiting for a solution :wink:

I’ve pushed a fixed associated with this defect

I post another link to a build you can download and test when it’s built

The OS X one is here … 1c_osx.dmg

windows and linux ones with fix here … 015-04-01/

@billbonney: Thanks for this quick fix. I will test it today in the evening.

Hmm, it’s still not working. Same message as before. I tested the OSX version … 1c_osx.dmg

Can you post the log as there are more debugging messages

The file is in ~/apmplanner2/log.txt

You can look also at debug message by going to help in the menu

Hey billbonney,

I’m having the exact same issue running the new Linux version. Still get the message that Radio Control isn’t active or turned on. I’ve attached screenshots of both my Radio Calibration Screen and my Failsafe screen. I’m using a DX6i transmitter with a 6 channel satellite receiver.

Understood. But I don’t have a DX6i to test with, so unless somebody posts the log messages it’s going to be hard to fix. They are in ~/apmplanner2/log.txt

Hi Bill

I attached the Log. I also had an eye on the logs and saw, everytime I click on “Calibrate” it bringts this message that channel 7 is out of range:

ERROR 2015-04-02T23:35:08.469 “isRadioControlActive: Error Channel 7 out of range: rcValue=898.000000”

The problem is the check for RC_CHANNEL_PWM_MIN = 900.0, and mine is reporting 898.0 :frowning:

What I did:

  1. Start APM-Planner
  2. Configured the Serial Connection
  3. Go to Radio Calibration
  4. Clicked on “Calibrate”
  5. Went to Failsave
  6. Back to Radio Calibration
  7. Clicked again on “Calibrate”

If you need some more information, just tell me.