Radio Calibration & ESC calibration in Pixhawk2.4.8

No not that update… I found something strange in mission planner in the radio calibration tab… I hope someone else can explain …. Why does it seem as there are multiple inputs

See picture …eg rol ( rc1) (rc1) (rc1) 0 … should be only one input

When there are no green bars at all in MissionPlanner radio calibration screen, then the receiver is not putting out anything at all, like it’s not even there.
You’ll have to put that setting back to S.BUS

J4NSS3NS meant there could be an update for the receiver. It looks like there are not any firmware updates.

You can also do that Arducopter update for the flight controller, but it’s not critical and wont change what you are doing now.

Please guide me bhai what can i do for fixing this problem.
one more thing that i forgot to tell you that I watch a video on YouTube that guide me steps -
CONG then FULL PARAMETER TREE then BRD then BRD_SAFETYENABLE=0 but the original value of “BRD_SAFETYENABLE=1” after watching that video i will changed it by BRD_SAFETYENABLE=0
then the radio calibration get this problem.
video that i watch on YouTube is:

from timing 18:04 to 18:11

BRD_SAFETYENABLE can be set to 0, that disables the “safety” switch, which is probably a good idea.
That is completely unrelated to the radio calibration issue.

Please bro guide me what can i do for fixing this problem.
If the flight controller get reset then this problem get solved or not ???

This no. of inputs increasing when i click on the radio calibration again and again .
please help me in solving this problem @J4NSS3NS @amilcarlucas @dkemxr @xfacta

I dont understand what you mean

When the flight controller successfully connect to the Mission planner then I click on the radio calibration then click on Mandatory Hardware then again click on the Radio calibration, then I saw number of inputs get double and repeat these steps again then the inputs is increasing step by step.

Giving reply to @J4NSS3NS

I searched my old dusty radio… I took the reciever fs-ia6b (simular to yours) and flashed 4,4,2 arducopter on a cube ( i dont have pixhawk 2,4,8) … as you can see it works out of the box … radio output was set on ppm sbus /// or pwm sbus worked both.

by mistake I turned my wire on pixhawk reversed and I had of course no connection at all…

I am pretty sure about wiring now … I think we are overlooking something trivial.

first 1. check the withe/red/black futaba cable… maybe it faulty. replace it with a spare one or measure connection with multimeter

second 2. check reciever ( is it powered enough, bind properly) best case you can test one if you find someone with same model in neighbourhood.

my guess it is in your wiring somewhere…

This is meaningless and has nothing to do with your problem. Anyone can generate that.

So what
Click off the Setup Tab and it will be normal again.

1 Like

@amilcarlucas @xfacta @J4NSS3NS @dkemxr
Thank you to all form giving me a powerful support.
I have fix that following Radio calibration by matching the parameters with another Pixhawak flight controller.

I have successfully completed the all mission planner “MENDATORY HARDWARE” options but while connect the battery to drone (using 3s lipo battery) the Pixhawk shows low battery by indicating RED led but the battery having efficient charge.
I has attached the screenshot from mission planner

Please guide me what can i do for solving this problem also…

The battery must be configured before starting the mandatory hardware configuration.

See How to methodically tune (almost) any multicopter using ArduCopter 4.4.x

I have changed the Pixhawk to another one , the new Pixhawk board not showing RED led but it shows “PreArm:Fence requires position” and I am not able to ARM my quadcopter drone.
I am attaching the above problem.

Please help me by guiding me how to fix this problem.

Poor GPS position. Just because it says “3D Fix” doesn’t mean it’s good enough. Wait…

I have changed my Quadcopter Drone frame then I go for compass calibration both compass 1 and compass 2 show the green region filled in column when the compass calibration is completely filled in the column then compass 1 shows blank column region(green region) and start again from starting.
I have also attached the video link below.

Please guide me the path how to over come that problem.

Compass calibration must be done after GPS configuration and requires GPS fix during calibration and no magnetic fields in the proximity. And if that doesn’t work you need to relax the calibration.

Seams like you still haven’t read the documentation. Please do.

Hello Dear
@amilcarlucas @xfacta @dkemxr @J4NSS3NS
When I connected the battery to my Quadcopter drone the Mission planner shows “PreArm: Yaw radio max too low” and I am notable to arm my drone

I have also attached the screenshot of the problem.

The channel that you use for yaw on your radio has a maximum value that is too low.

Re-do radio calibration step.

Pre-arm messages are found here for future reference:
Pre-Arm messages

1 Like