Radio calibration channel issue

I’m new to ardupilot. I’ve recently bought a Matek 405 wing fc and am planning to put it on a nano talon.
I’m using a crossfire nano rx and Taranis x9d radio (mode 2).
My issue is when I open up misson planner and go to the radio calibration page, the channels are set wrong. When I move throttle it moves roll on the radio calibration page. The pitch and elevator are set wrong to. The only channel that works right is yaw.
I’ve tried changing the settings on the servo output page but this doesn’t help.
I’ve uploaded a short video to help explain.

Check what mode selection you have in your radio… this assigns which sticks drive which channels in the rc signal,
Choices are mode 1, 2, 3 or 4

This is what ArduPilot is looking for
you need to fix the Channel out put of the TX

Ch1 = Ailerons

Ch2 = Elevator

Ch3 = Throttle

Ch4 = Rudder this is wright why the rudder works as it should its the right channel

Thanks for your help.
I’ve sorted this issue out now.

Was it just the tx mode? If so what was the correct mode selection ?

It was already set to mode 2 but the channels on the radio was in the wrong order. So set it to A,E,T,R.