Quicktune yaw hıgh oscillation

I tried quicktune for my 24kg quadcopter today. RLL and PIT axis completed and looked there were no problem. After PIT tune done copter went crazy I disabled quicktune and landed in althold mod.
In datalog looks like oscillation started right after PIT done before yaw axis started.

Copter is stable in althold and loiter in current parameters.


T-Motor BLDC and Prop

Waiting for your guidance. Thanks in advanced.

I think there are quicktune improvements in 4.5

Can you update

1 Like

Hello again,
I didn’t want to update firmware for now to not to encounter unexpected promlems so tried manually tuning. I used last flights quicktune data and set pitch and roll values which quicktune has found.

Problem about the yaw is small pilot yaw input cause high turning. I searched the forum. In a few posts they say decreasing ATC_ACCEL_Y_MAX solves the problem. I lowered parameter to 6000 and 4000 from 9000 but looks like it didn’t work.

About roll and pitch, I have more control on the copter but it’s much more sensitive to inputs and something doesn’t feel right.

Copters load will be 18kg btw. All the tuning made without load.

Here is a video, bin and param file.


Quick tune is great when it produces results that are satisfactory.

But when that is not the case you need to tune further for instance with autotune.

Use ArduPilot methodic configurator to guide you through the safest and most efficient configuration sequence .

Use the software because it contains details that are not in the blog post.

After that, post a .zip file with the .json and .param files.

I looked at the latest log.
There is no downside to upgrading to the latest stable firmware, there’s no major changes to tuning or behaviour but there are some bug fixes.
EDIT: In fact improvements to Autotune

I would set these for the T-Motor ESCs


then check and reset your MOT_SPIN_ARM and MOT_SPIN_MIN
You might even need to change the thrust expo to 0.4 or 0.6 but we can probably leave that until later and we see some more ascents and descents.

Change the filter settings:


For the sensitivity and yaw:


Motors 3 and 4 are working harder than 1 and 2 to counteract a physical yaw issue. This is usually motor mounts twisted, and it can be very slight and hard to see. This affects yaw, and can even affect pitch and roll in certain manoeuvres.


See how it flies after all that.
I’d like to suggest more PID changes but will wait for the next lot of flight data.

All of those parameters are on the ArduPilot methodic configurator software. You just need to enter their value as @xfacta described.

Combiing the sequence from the configurator and the values from @xfacta will get you the best results.

And do post a .zip file with the resulting .json and .param files

I will update you in a few days with your suggestions.
Thanks for your interest.

Hello again,
I made a flight today with your changes.

Updated the firmware to 4.5.4.


is still 1000 cause motors starts to spin at 1050 at idle. I don’t think there is a calibration issue. Their speed looks the same.


is still at 0.2 according to T-motor suggestions on the forum.

I changed the parameters for filter and yaw which you gave to me and I lowered ATC_RAT_RLL_P,D ATC_RAT_PIT_P,D %10 percent myself.
Control is softer now on roll and pitch. Yaw has got very slow, however it doesn’t overshoot so it is better for me.
I tried to level all the motors again but it looks like not perfectly leveled according to RCOUT data. I am gonna look for a solid solution.
I updated the google drive file with a video, bin file and param.

Did you post the .json file as well?

I flew with manually changed parameters but I used configurator and tried to update the files. I entered some with my configuration values and others what configurator says. Uploaded zip file to the drive link.

@xfacta @amilcarlucas have you got a chance to look into the files ?

I do not have a PC right now. But in a coupleof days i’ll have one.

Did you add ALL “reason changed” fields?

Did you edited all fields in the component editor window?

Did you add a vehicle.jpg file?

Did you reached the end of the configuration sequence?

I added all the necessary reason changed fields.
Edited component editor.
Added a vehicle photo with that name but it doesn’t apper in the config I don’t know why.
I reached the end of the all the files to the summary.

I used hobbywing X11 template.
Only the Temp_calibration _results file is not valid cause I did calibration long ago.
I have SIYI GPS and Emlid RTK, GNSS file is for SIYI GPS.
As I said I have done quicktune already so I entered quicktune found PID earlier than quicktune file. I explained which ones.
I entered xfacta’s parameter values as he said and I wrote Xfacta suggested next to them.
From the start with Autotune files I kept them default cause I need to complete PID adjustment first.

I think I should try to fly with these new param. Maybe try quicktune again I don’t know.
Correct me if anything wrong with the file.
I can remind you again till you get a PC.


The vehicle photo must be named vehicle.jpg as explained in the component editor window

It appers now. I will be waiting for the feedback.

You did some small mistakes in the files, that I now corrected.

Some questions:

On file 15:

  • did you do thrust stand tests to proof that the EXPO is 0.2? I tested Alpha ESCs and got values between 0.5 and 0.65 on my tests. It does also depend on motor and props.
    Without a correct EXPO value the throttle based notch will not work correctly.

On file 23:

  • why did you subtract 10% from the quick-tune values?
  • Why did you ignored the yaw quick tune?
  • You are only supposed to accept the quicktune values, nothing else.

On file 27:

  • why did you not repeat the quicktune after the magfit flight?

AGRI_UAV.zip (424.0 KB)

Thanks for the reweive.

I didn’t do a trust test. I might be got confused by the forum posts about t-motor. On ArduPilot Motor Thrust Fit spreadsheet 0.83 look like close to the correct value but there is no propoller input on that sheet. as I see.

I couldn’t complete quicktune. Copter went crazy just before yaw tune start so only took PIT and RLL values. I entered those values and made a flight again however, copter felt too aggressive and not stabile as it was so I lowered PID %10 to try. You could see the difference on the last two videos.

I could do a quicktune again after correcting MOT_EXPO and related values.

I advise you to try and find thrust test data from the ESC Motor and Prop combination that you have in the internet.
And then use that data to estimate the correct MOT_MIN and MOT_EXPO parameters.

I also released a new “ArduPilot Methodic Configurator” latest version today, that fixes some presentation issues

So I set MOT_THST_EXPO 0.4 and configurator values today but I couldn’t even take off. I set MOT_THST_EXPO to 0.2 again and it didn’t effect anything. There is and other problem. It was like stabilize mode middle stick doesn’t hold altitude.

I updated drive file with a .bin file and a video.

I looked at the video. Looks like instability at low throttle.

So like explained in section 2.16 of the Blog post:

When MOT_THST_EXPO is set too high you can see instability at low throttle and
when MOT_THST_EXPO  is set too low you can see instability at high throttle.

So yes looks like 0.2 is a better choice.

The bin file does not seam to match the video.

Post the latest .zip file as well.