Quadplane yaws left in hover

Hello all,

I’ve been working on an FX-79 quadplane build and am have started hover testing. However, when it takes off it seems fine for about 1-2 seconds the starts yawing left and I can’t get control of it. Here is a video: https://www.youtube.com/watch?v=5EbzGHl4CL0&feature=youtu.be I have tuned the quad PIDs to get rid of vibrations seen in the video, but it still does that yaw left. The CoG is slightly forward of the center of the quad motors, but not by much. I also noticed the compass offsets were fairly high, so I tried moving the GPS out near the nose and a bit higher, far away from any power distribution but still saw the same effect. Any thoughts would be very helpful!

The dataflash log contains a couple takeoffs in qloiter and qhover.
2017-08-14 18-53-39.bin (439.1 KB)

Did not look at your log, but are you running X or H-Quad setup?

Got it wired up and the parameters configured for an X setup. I guess the frame isn’t actually an X, would that make a big difference?

If I saw it right in your video, the motor arms are running front to back under the wings, so X should be the right choice.
It makes a difference. Quadplanes flex even more than a multicopter and that flex creates thrust vectors that might cancel out the torque needed to yaw the airframe. So you want a setup where the thrust vectors add up with the torque.

I tried switch the frame calss to H-frame and reversing all the motor/prop directions, and no longer have any unwanted yaw! Thanks for the help!

3 Likes

How did you have your pixhawk orientation ? I am trying to do the H frame,yaw issue solved, but heading is 90 degree to orientation of pixhawk in quad mode, but normal in plane mode. what to do?

My pixhawk was just facing straight ahead, didn’t have any problems after the H-frame fix.

You may have already checked out your AHRS_ORIENTATION and COMPASS_ORIENTATION params, but worth looking at those again. I have also seen some magnetometers that are just hard to calibrate, whether it be their environment onboard the plane (check for DC power cables or magnets) and occasionally flying using COMPASS_LEARN helps.

Hopefully that helps!

in H Quad the heading is like :arrow_right: or :arrow_left: but my plane heading is :arrow_up: ^. if i am keeping the quad motors in other numbering or directions i am having yaw/wobble issues.