Servers by jDrones

Quadplane Hover Tests Done, Tuning Advice Needed Please

Hoping for some guidance here: I’ve done some basic tests on my Quadplane in rotary wing mode (no transition as yet) and I’m looking for some tuning tips. Whilst I have 3 fixed aircraft flying well on Pixhawk, I have very little experience with Copter firmware (all my rotary wings are DJI). The aircraft was well baselined in fixed-wing mode, having done 10+ flights (before the Quadplane mods). I have tried Qhover and Qstabilize modes and these are my observations:

  1. The aileron/bank control and pitch controls are very sensitive to stick input – do I lower the Q_A_RAT_RLL_P and Q_A_RAT_PIT_P?

  2. I am find that I need to maintain forward stick to hold position – is there a way of fixing this?

Thanks,
Jacques

Did some ore tests today, at first I tried lowering Q_A_RAT_RLL_P and Q_A_RAT_PIT_P all the way down to 0.1 but discovered it was not very stable. I then put them all the way back up to 0.25 (default values) and things were much better. I played around with QHover and QLoiter modes and discovered that the hypersensitivity to stick input is only occuring in QStabilize mode so I guess I just won’t use that in future. So, all is fine, apart from the tendency to drift backwards in non-GPS modes (QHover and QStabilize). The booms are pretty much level with the the lower surface of the wing and the plane was well baselined in it’s fixed-wing only configuration, so I’m not quite sure what to do. Not a major problem as I can just use QLoiter most of the time (except when transitioning from fixed wing flight to rotary wing, as that will supposedly stress the airframe).

@jacques_eloff,
The rate parameters (the ones starting with Q_A_RAT_) are not the right ones to reduce the sensitivity to stick input. A log would tell me more, but I would instead suggest:

  • lowering LIM_ROLL_CD and LIM_PITCH_CD. That will lower the demanded angle when you move the sticks in QHOVER. I will be changing it to use the minimum of Q_ANGLE_MAX and those values, but for now the LIM_* parameters are the key
  • if the demanded angle is OK but you don’t like the rate it rolls at then lower Q_A_ACCEL_R_MAX and Q_A_ACCEL_P_MAX. They are the roll and pitch rate limits in centidegrees/second

Posting a log could be helpful.

@tridge,
Thanks, I’ll try changing Q_A_ACCEL_R_MAX and Q_A_ACCEL_P_MAX in that case.
Can you remind me - is it log or bin file that I need to pull?

Many thanks,
Jacques

I’ve pushed the fix for Q_ANGLE_MAX into master. Previously if you asked for maximum roll in a quadplane you would get LIM_ROLL_CD. That is often quite high (50 to 60 degrees). That makes it far too sensitive to stick movement.
Now maximum roll will be the minimum of Q_ANGLE_MAX and LIM_ROLL_CD. So you can lower Q_ANGLE_MAX to limit angles in QHOVER and QSTABILIZE. The same applies to pitch.

bin files are preferred

@tridge

I couldn’t upload the .bin file to this thread, so I have uploaded it to dropbox here:

Hopefully you can retrieve it?

I’m interested to see what you find. Note that I have dialled down Q_A_ACCEL_R_MAX and Q_A_ACCEL_P_MAX to 7,500 which seems to have softened the responsiveness in Qstabilize and Qhover modes slightly. But I still prefer the much softer feel in Qloiter. Can you check the default values for these parameters when Quadplane is enabled? The 110,000 value equates to 3 full rolls per sec, if it’s centidegrees?

Had a slightly scary moment when RTL was triggered, as I was flying the packs all the way down to check duration. Fortunately I did not have the forward motor prop on and toggled it out of RTL (testing on a football field, but it’s in the middle of a residential area!)

Appreciate you are a busy man, so no rush.

Thanks again for everything you are doing to support (and lead!) this community.

Jacques

@tridge I was able to use Q_A_ACCEL_R_MAX and Q_A_ACCEL_P_MAX to soften the controls in Q Hover but in Q Loiter Q Land and others that use GPS repositioning seems it does not use these 2 parameters for input. In any other Q mode the input is really sensitive to the point that over correction is really easy and dangerous some times. In Q hover it is really stable and controllable. Is there another setting to use to soften input for these other modes? Thanks again for all the work you guys do.

@TTGold have a look at the tuning doc here:
https://ardupilot.org/plane/docs/quadplane-vtol-tuning-process.html

@tridge. Thanks for the reply. I actually tried to follow this specific doc all the way through. This is how I was able to get a flyable quadplane in vtol. I did end up lowering the accel parameters all the way down to 18000. The only thing I haven’t tried is setting the Q_A_ANG_LIM_TC. Do you think this would make a difference in QLoiter? Overall the tune seems pretty good other than just the rc input sensitivity in Qloiter now.

Servers by jDrones