QuadPlane Full Pitch Flip in Transition from VTOL to FW – Near Crash


When flying a Quadplane (Pixhawk, ArduPlane V3.8.0beta5) mission in AUTO mode, transition from VTOL to FW resulted in very high pitch and roll angles (with wind about 4 m/s) at about 50m of altitude. Aircraft is saved by changing mode to “QHOVER” and landed safely.

I dont have DataFlash logs due to “No IO Thread Heartbeat” error, but .tlog and videos (from ground and from onboard camera) are provided below.

TLOG: https://we.tl/XvwpnEK9Q5
Ground Camera: https://youtu.be/KU2FtkbCICE
Onboard Camera: https://youtu.be/WCSC9HqdnOI

I see that before transition started, the aircraft was hovering fine in the wind with attitude oscillations (Pitch: -12deg, Roll:13deg). When FW THR (% 100) is applied, attitude changes very fast (Pitch: 23deg, Roll:-25) and reaches up to very high values (Pitch: 61deg, Roll: -121deg) with the help of the wind.

So, my suggestions are;

  1. Angle and angular rate limits may be defined before switching to FW, in order to ensure that the aircraft is not moving prior to applying full FW throttle.
  2. Instead of applying full FW throttle instantly, a time interval may be defined so that throttle rises gradually, as in shutting VTOL motors with Q_TRANSITION_MS. This would also decrease power demand at the beginning of the transitions and improve altitude loss due to instant voltage drop.

Any other opinion?
Best Wishes,

Hi Ferit,

We have a similar issue thread in the Developers forum. Please look at the thread and videos to see if you think they are the same issue.

QuadPlane Pitches Up using v3.8.0 beta 5


Hi @GregCovey,

I looked at your thread about pitch up issue. I think they are not the same, because yours seems to be happening around reaching transition speed (near the end of transition), and mine occured at hover (at the beginning of transition). But there is a similarity by applying maximum PWM commands to forward VTOL motors (explained in the below post).

Also I see that you experience some torsional twist of wings and arms, which is not my case. My airframe is full composite with a takeoff weight of 6.6kg and I dont see any twist in videos from the ground and onboard camera.

I have another quadplane (converted from Volantex Raptor FPV V2) as shown in the picture below. I inserted 2 composite rods in the wings in order to minimize the twist of the wings due to quad motor. And I had no problems with this airframe in transition maneuvers using ArduPlaneV3.7.1 and V3.8beta5.

Best regards.

I can’t look at the tlog as it has been removed, but I suggest you check in the log for changes in battery voltage on transition. What you describe can be caused by several things, most commonly:

  • wing twist
  • battery sag, so VTOL motors drop out

Hi @tridge,

Tlog File: https://we.tl/roqXFLauuW

  • Wing twist: Body and wings are full composite and very tightly fixed. So I dont think this as a problem.

  • Voltage Sag: Voltage at the time of incident drops down to 20.5V instantaneously. But I dont think this is the problem, since I had successfull auto flights with battery voltage down to 20.2V.

I checked my “.tlog” file and found similarity to @GregCovey’s incident (QuadPlane Pitches Up using v3.8.0 beta 5). Logs show that high PWM commands (same PWMs to both motors) are applied to forward VTOL motors prior to pitch up.

@GregCovey experieced the similar situation at the end of the transition maneuver (in my case at the beginning of transition), with 2 motor recieving same PWM commands causing pitch up maneuver.

Best wishes,

Hi - I know this is an old post, but do you still have tlog? I have added full OSD support for quadplane into MWOSD and need a tlog to test it.

I would be glad if you could share your results.

Best wishes

Thank you for file. It’s really helpful. If you are not a user of MWOSD and want to try at any time, let me know and I’ll arrange for you.

It looks like a waypoint flown flight until the end until hover mode enabled and landed manually – is that about right?
In top left for MODE, I can see QLAND very briefly and then QHOV engaged at around 04:26 and then aircraft lands so it looks promising.

Here is video capture of playback. It is unliste d- let me know if wnat it removed when reviewed:

Below are the modes available in MWOSD. In minimosd-extra firmware, only the first 3 Q modes are currently supported.

“QSTB”; // Quadplane - like copter STABILIZE
“QHOV”; // Quadplane - like copter ALT HOLD
“QLTR”; // Quadplane - like copter LOITER
“QLND”; // Quadplane - like copter LAND
“QRTL”; // Quadplane - like copter RTL
“QACR”; // Quadplane - ACRO