Quad Motor VTOL Tail sitter No control in forward flight. QHover is good

I’ve built a quad motor vtol with no control surfaces. Arduplane 4.15. It’s been a learning curve but I’m up to the point where it does pretty well in QLoiter.

First issue is that I followed the motor layout on the VTOL quad sitter plane. It hovered but wouldn’t yaw. I changed the motor direction to match Arducopter X layout and now it yaws and flies pretty well in copter mode.

Today I tried FBWA. It transitioned well and flew straight as an arrow towards the horizon but I had zero stick control of it. I understand some vtol models depend on vector thrust but I thought I had all the settings correct for motor based control in forward flight. (i.e. Swan K1)

Q_FRAME_CLASS = 1 “Quad”

Q_TAILSIT_MOTMX = 15 (Motors 1, 2, 3 and 4 are selected and nothing else is selected)
Q_OPTIONS = 128 “Force QAssist” Nothing else is selected.
Q_TAILSIT_INPUT = 0 (in hover the aircraft responds like a multi-rotor)

Did I miss a setting or settings to use motors to control pitch/roll/yaw in forward flight?



1 Like

Issue was lack of authority in FBWA not lack of control. Issue has been solved.

1 Like

Do you have a youtube channel?I want to do this project.

No YouTube little information here