Quad flips when taking off, motor orientation and direction checked

So are you gong to stick with the 4S battery or smaller 3S battery? How you advance depends on this. We can use these logs to start tweaking some parameters if you stick with 4S.
And you missed the Accel filter value change I noted above.

I guess I’ll stick with 4S. Is that what you would recommend?
Unfortunately it started raining here for the rest of the day so I won’t be able to do any more test flights until tomorrow.
Also, do you have any idea what may have caused the quad to go into failsafe mode midair?

Battery failsafe. It was down to 13V and it doesn’t look like it was fully charged assuming your battery monitor is calibrated.
Set these to continue with 4S:

And read thru this and set the MIN value correctly:
Setting Motor Ranges

1 Like

I am going to watch in the background see if I have missed any thing Dave,it is so kind how you help people you are A genuine star thank you from me and my bow wow

I set all of those parameters and did another test flight. It still felt quite unstable but could fly. Unfortunately, it still gave me a battery failsafe warning and disconnected the drone. That was at a battery voltage of 15.5, which then dropped below 15 when flying, causing the failsafe. I think the 4S battery I’m trying to use is old, since I can’t get it to charge past 16.48V. Should I switch back to 3S?

I will recharge the 4S battery as far as I can and try another flight, and send you the log for it.

What do you mean it disconnected? And unstable how?

What do you mean it disconnected?

Disconnected as in I could no longer control it with my transmitter because a failsafe was triggered.

unstable how?

Unstable as in slight movements on the sticks cause oscillations in the drone’s movement midair (something I assume proper PID tuning would fix).

Anyways, here are a couple test flights.
With 4S battery:

With 3S battery:

That last one with a 3S 3600mAh battery was the longest flight I’ve been able to sustain yet. It was probably around 1.5 minutes, and then the battery failsafe triggered again.
How do I get longer flight times? All the batteries I’m using are pretty old. Would new batteries help? Do I need to find a way to remove some weight? I’m not sure what else to remove.

How big is the 4S battery? Based on how quickly the voltage dropped I’d say that battery is done. Either way, you need to pick a battery and stick with it. You can’t go back and forth and expect to get it tuned because many of the characteristics of the flight will change if you change the battery voltage, the weight, the position of the weight, etc. Pick one and stick with it. If your parts will handle 4S, then I’d say go that way.

I looked at the 4S log, and there’s some vibration that needs to be addressed. check your props, mounting, the flight controller. Make sure there is nothing bouncing or vibrating on the controller. Make sure none of the wires are pulling tight on it either. Those F450 frames are bad for vibrations, as Dave has already pointed out. You won’t get it perfect as other similarly sized frames, but it needs to be better.

As per the wiki, you probably want to reduce the PID values some to get it flyable, but that seems strange to me, because defaults on an F450 should be pretty flyable. I’ll let Dave suggest some better tuning choices from here.

1 Like

Get a new 4S battery that weighs no more than the shot one you are using.
You had a battery Failsafe and it entered Land mode. It didn’t “disconnect”.
Set these:

As @Allister mentioned the vibe levels are high but they are hard to tame with the junk f450 frames. Balance the props or better yet get new props that are not plastic spin-ons and balance those.


New 4S 4500mAh batteries are on their way, arriving next Monday. I think I should be able to get my hands on some better props soon as well. Thanks for the continued support.


Jacob,there is nothing better than having a good flying Ardupilot, im 72 now and get so much enjoyment out of tinkering with it and I have the biggest smile after a mission and all ways some thing to learn or try Allister,Dave and Shaun do so much to help the community they should be knighted arise your Sir’s,


Some simple advices from France:
-have you tried to take off in loiter mode?
~ regarding the weight, 4S is recommended, check that motor and ESC are 4s compatible
~ fix your quad on the ground and push the throttle to check if your quad is highly vibrating, specifically the propellers
~ is your Flight controller installed on anti vibration pad?
~ disconnect all the un necessary stuff (camera, telemetry, etc.) as you might have an interférence issue
~ make sure the buzzer is far enough from the flight controller, it could cause interference
~ hope it could help
All the best


I just had a pretty successful flight with the new battery. The instability issues seem to be mostly gone. I think getting a better battery solved most of my problems. Here’s the log if you have any other suggestions. Next I will try loiter, return to home, and do an auto tune.

Edit: I should mention, I was not able to get better props yet.

1 Like

A Tlog is not useful.

1 Like

Whoops, my bad. Here’s the bin file.

1 Like

Nice you are seeing light at the end of the tunnel Jacob,some awesome people helping you

1 Like

Update to latest Stable (V4.4.0)
Tuning is poor and the Notch filter settings surely won’t work. Related perhaps, you can’t set a Notch filter centered on 10Hz. Set these:

Then run Auto Tune.
After that I would suggest you run Magfit for compass calibration. Not because there is a particular problem simply because it’s the best procedure to use.

1 Like

Hello again! Quite a bit has happened since the last time I posted here. I crashed my F450 frame and got a new HolyBro X500 frame. Now I’m trying to get this one tuned. I’m still using all the same electronics (same 4S 4500mAH battery as well). Unfortunately I still haven’t upgraded my props. Here’s a picture:

I have a log file of my first hover. Do you think you could take a look at it?

Secure the GPS cable.

There’s quite some difference between clockwise and counter-clockwise motor outputs, indications some arm or motor mount twist.
This is giving you a double-peak in noise too. Adjusst these Harmonic Notch filter values and it should be good for now and when you fix the motor mounts, but it will have to be rechecked at some point.


Also try increasing the Angle P’s

On your RC transmitter, check there are no trims, and maybe do it’s hardware/built in calibration again, then redo the RC calibration in MissionPlanner or QGC

I updated those values, here’s my flight log:

I still noticed a lot of oscillations. The frame and arms seem sturdy to me. I secured the GPS cable. I know my props aren’t very good, could that be it? Do I need to put my flight controller on an anti-vibration plate? I also have a TPU mount for the GPS so it can bend over if the drone falls over, is that a bad idea? Does the GPS need to be sturdily mounted and unmoving?