Quad flips when taking off, motor orientation and direction checked

I’m building a quad using the f450 frame and a Pixhawk2 Cube Black. I have set initial tuning parameters to 10in props, 3s battery, 4.2 high voltage, and 3.3 low voltage. I have done all accel calibrations. I have done the compass calibrations inside and outside. Radio calibration is good. I individually calibrated each esc. In motor test, I verified that the motors all spin in the right order (A, B, C, D in clockwise order with A being the front right motor) and that all spin in the correct direction with the correct propellers mounted on each motor.

I try to take off in stabilize mode. The quad arms, and I increase throttle very slowly until the quad moves. As soon as it gets enough throttle to take off (presumably, it doesn’t actually get off the ground at all), it immediately pitches up, and quad tips over towards its back. I’ve double checked everything that I did above and retried the flight many times, and it does the same thing each time. What am I missing?

Edit: I do realize that the red arms are supposed to be facing forward. I messed that up when building it but I promise all the electronics are configured to face the same direction as the Cube.

Just to be clear the red arms are on the left side of the quad?

Some things to check:

When you move the pitch stick forward on the RC, does the green bar on the calibration page go to a lower or higher value? It should go to a lower value. This needs to be reversed on many RC links.

When you move the quad does the HUD on mission planner move the right way?

  • Yes, the red arms are on the left side.
  • When I move the pitch stick forward, the green bar actually goes to a higher value.
  • As far as I can tell, the HUD moves the right way. When I point the quad down, I see the ground (green) and when I point it up, I see the sky (blue). When I tilt it left, the horizon slopes down (from left to right on the HUD), and when I tilt it right the horizon slopes up.

So if I reverse the pitch on the RC, would that solve the issue? Should I reverse it on the radio or in Mission Planner?

Update: I just tried reversing the pitch channel (ch2) on my radio. Now when I push the stick forward, the pitch value goes down in Mission Planner. I recalibrated the radio. However, when I tried it, I got the same response from the quad. It tips over backwards.

Post a link to a .bin log file of a take-off attempt.

You can reverse it in either place. You’ve done the radio so that should work.

Like Dave said, post the .bin log from the flight controller for the attempted take off.

To be clear, you aren’t doing anything silly like trying with a tether or inside without GPS?

Or fiddling with the Trim sliders on the Transmitter?


Here are a couple log files. I did make a change to the copter before logging these, but the quad still tips over, only this time to the left instead. I removed the raspberry pi and antivibration platform from the top, because I noticed it was tilting the Pixhawk board slightly up and to one side. I now have it mounted flat on top of the copter. I then redid accel and compass calibrations. Unfortunately it didn’t really help.

The motor outputs are reaching near max. Even on 3S that quad should be airborne. Is it tied down?

Yea, agree with @Allister . What motor kv and what’s the take-off weight with the battery?

This was it-- I had the trims way off center from when I was flying a different model on the same profile. It now takes off without tipping, but I don’t dare fly it more than a foot or two off the ground because it looks very unstable. Time for some tuning I guess. Thanks!

Time to provide that log to get a indication of thrust/weight.

Best thing to do is disable trims for this model.

Weight it about 3 lbs (using my bathroom scale so probably not that accurate) and I’m using 920kv motors.

Thrust/weight looks too low. If it is at 1.36kg it’s too heavy. Provise another log where it’s hovering for a minute or so and set these:

Any idea what’s causing it to be overweight? I don’t have anything extra on it. I assume many people have made similar drones using this f450 frame. The battery is 5000mAh, is that too much?

Many people have. Yes a 3S 5000mah battery is probably too heavy. You don’t want to be much over 1kg with that set of components.

Make the hover flight anyway you need to establish a hover thrust value in any case.

Ok, I do have a 3S 2200mAh battery, I’ll use that for now. I assume I’ll probably want to use a 4S battery eventually?

Maybe, if the motors and ESC’s can handle 4S. You will want better props. Those plastic spin on’s are terrible. With the FC mounted direct to those noodle-like F450 frames high vibrations are likely. But we’ll see from the hover flight.

I set those parameters. Also, I found that I had a 4S 4000mAh battery to use and installed that, and updated initial parameters. I tried some flights, but it was basically impossible to stay hovering for a full minute. The controls are extremely touchy. Also a couple times I got it in the air for 10ish seconds and then it disconnected (the LEDs on the GPS turned yellow) and it started flying upwards, so I had to disarm it and let it fall (on the last one it fell far enough that the landing gear broke off). Here’s some logs I took: