QIOTEK Zealot H743 - Relay - how to enable

Hi - anyone got relays working on Zealot H743 - its kicking my butt.
Im running Ardurover 4.4-beta 11 which is working well

Zealot info is here QioTek Zealot H743 — Copter documentation

I’ve cabled into the ADC2 port which has Gnd, Adc2, Relay1 to Relay4
Multimeter shows 3.3v across relay1 to relay4 regardless of what the Servo’s are set to on the Relay panel of mission planner. Im expecting 0v or 5v (low or high)

Specific questions

  • which are the AUXn pins - are these the RELAYn eg ADC port?
  • if not the relay1 to 4 pins then can i use SERVO pins eg Servo10,11,12,13.
  • do the Servo ports need to be set to GPIO for the relay ports to work ?

Thanks in advance.



Actually, I think these pins are different, and not on main/aux busses at all. If I’m interpreting the hwdef.dat correctly, they are GPIO 1-4, meaning that you should set RELAY_PINx to a corresponding number, 1 through 4, to get them to work as intended.

Yea, looks right. Already configured for GPIO/relays.

All of them. FC doesn’t have a IOMCU.

Just confirmed via bench test.

So, if you want the QioTek output labeled Relay1 to be triggered by ArduPilot’s RELAY_PIN2, set RELAY_PIN2=1.

No need to touch any SERVOx parameters.

Of note, RELAY_PIN and RELAY_PIN2 act on GPIO pins 1 and 2 by default.

And, just to confuse things more, Mission Planner’s Servo/Relay tab uses a zero index, so RELAY_PIN2 is actually toggled using the label “Relay 1.”


Clear as mud, I’m sure…


Not that it matters as Ardupilot rules here but the Manual link on the Qiotek website isn’t working. Cloudflare bullshit. So perhaps they or the retailer that posts on the forum here can fix that.

@timtuxworth is the guy for that.

And perhaps @Eosbandi would be so kind as to update the relay button labels in Mission Planner to just repeat the parameter name with which they are associated “RELAY_PIN”, “RELAY_PIN2”, etc, rather than the confusingly zero-indexed labels at present.

1 Like

Thanks folks - thats amazing fast response and appreciated.

> Yuri - values 1-4 on RELAY_PIN1 to 4 Perfect ! - thanks.

I’ve had non-default values in there - so looks like it would have worked out of the box if i didnt copy my parameter set across a while back. These low values are undocumented - but i noticed the default values while posting at the top.

The documentation suggests they are +5V values. Im seeing 0v or 3.3v - all my relays to hand seem to be 5v logic. Thats an easier one :slight_smile:

Most STM32Fx and STM32Hx autopilot GPIOs are 3v3 out and 5V tolerant for input, so that is unsurprising.

I must admit I don’t really understand relays and maybe @Qiotek can help, but if it helps at all here is the manual.

We already solved the question at hand.

The manual link is broken on QioTek’s own site.

However, that wouldn’t have helped at all if the one you linked is all that’s available.

1 Like