QGroundControl custom build APM

Tried the apk. Couldn’t connect via bluetooth or USB. The stock QGC connects normally.

1 Like

Hi , i didn’t try the USB/Bluetooth comunication . Only UDP . Recentley i compiled the last 64 bit version (4.0.3) . I changed the signature so now it’s possible to install without remove the official release. On Linux environment, the serial comunication work. Anyway I will try to investigate. Thank for the feedback

Changelog

  • Merge from 64 bit 4.0.3
  • Widget proximity sensor 1 on the screen
  • Changed package name to avoid conflict with official release

Hi, I tried to install the QGCustom4_0.apk version on my LG K11 Plus with the Android 7.1.2 version, I receive a message saying “This app is not compatible with the phone”.
The CustomGCS3_0.apk version was installed successfully.

I’ll give it a try with this version.

hey @DomenicoPatella
Still no luck with USB and Bluetooth.

Ok sorry , i just compiled for 64 bit , I will deploy 32 bit version also in this post

Excellent, I’ll wait for the 32 Bit version.

Release APK 32/64 bit

Thank you for this excellent work.

1 Like

Thanks, great job! Is it possible to have the video in foreground from Eachine ROTG01?
I use wifi telemetry

Hi , thanks
Read the post below, UVC is not well supported but there is a soluition

1 Like

Hi, thanks Domenico I try it asap :slight_smile:

Hi Domenico, i try put in QG (videosource RTSP video stream) HTTP://ip:8081 or rtsp://ip:8554/live from easycap but don’t work. where am i wrong? Thanks

There are user and password to set. Go to settings and clear or change it. The string to set appear on USB camera app when you start the service.

1 Like

Try to watch the video But remember to clear the password in settings

https://drive.google.com/file/d/11A-OGCwi3tRERx-HBpA9H-aja8g6gG_o/view?usp=drivesdk

1 Like

Hi there, Thanks for sharing.
how can I build this custom QGC?
I build the official version without any problems but I get an error for building this!!!
Can you tell me what prerequisites are needed for compilation please?
I use Qt Creator and Ubuntu.

/home/tesla/Qt5.12.6/5.12.6/gcc_64/include/QtCore/qvariant.h:399:16: note: because ‘QVariant::Private’ has user-provided ‘QVariant::Private::Private(const QVariant::Private&)’
  399 |         inline Private(const Private &other) Q_DECL_NOTHROW
      |                ^~~~~~~
12:47:41: The process "/usr/bin/make" exited with code 2.
Error while building/deploying project qgroundcontrol (kit: Desktop Qt 5.12.6 GCC 64bit)
When executing step "Make"

Hi there,

How do I build the QGCustomAPM-r4.1 branch in QTCreator using Desktop Qt 5.12.6 MSVC2017 64bit?
When I try to build I get the following errors.