Servers by jDrones

Qground Control Sequence Error

I am having same issue here . Some times it will instead say vech did not request all mission targets or some thing along those lines . Tower crashes my tablet every time . I am totally clueless about this stuff but , after reading a wack of msg board posts I remember reading some thing about lowering baud rate … packet loss something or other . But I have no idea where to change that setting . He’ll I can’t even figure out how to read a log file now that I know where they are on tablet . .

The “good” log file isn’t on the tablet. That’s just the one the app recorded. You should pull the micro-SD card (assuming you have one) out of the SV. If you don’t have one, put one in there. It’s used for storing higher quality (relatively) video/images, GPS quick fix data, and dataflash logs.

Yes I have SD card in SV , the one that came with it . I know about data flash logs and can read them in raw form in note pad on tablet .; but If I have Tower installed on the tablet if I try and open a SV data flash log . Tower will automatically open and then crash with a critical error msg popping up.

What I was talking about in my above post is the Tlogs that Qground creates and stores in a folder in tablets memory if I have Qground connected when flying . These logs I can not figure out how to read them, it seems android version of Q has no way to display log files that I can figure out .

Transfer the DATAFLASH logs from th SD card to your PC and use Mission Planner or APM planner 2.0

the tlog is useful for plotting the movements of your drone, but (correct me if i’m wrong) don’t contain all of the logs. It’s just telemetry. I don’t really know the difference honestly. either way, open up the dataflash logs in mission planner

Mobile builds of QGC do not have log replay support. Only desktop builds have that feature.

2 Likes

ChrisOlson shared this advice

I’m still unable to achieve more than Arm and Takeoff while in QGC. After takeoff, I can switch to Auto Mode but the vehicle Loiters only. I have not been able to Load the mission from QGC.
The parameters changed in my 2450 are attached.
Any insights will be appreciated!

1 Like

Andrew I am having the exact same issue as you . I can some times get it to upload 3 or 4 way points, If I sync multiple times . I can’t get Tower to work either , app crashes on tablet. I don’t have a pc, that I can use to load mission planer to see if that works .

Are you guys on stock SV firmware, or master? I was using Tower just the other day and my SV loaded and flew the plan just fine.

1 Like

Neeko, my Skyviper is stock running what I assume is the latest SV firmware . Am I correct in thinking the app updated and pushed to drone automatically ? I was able to conect with Tower back in January but weather was never good for flying so I was just playing around trying to learn the basics of how the planning worked . Also I was having an issue then with error msgsaying bad loging and no i/o Heartbeat or something . Things went quickly out of wack shortly after that with me making two errors and disarming the drone accidently while about 25 feet resulting in a broken front left arm being completely broken right where the flange is for the two screws join it to the body , I replaced that motor with the wife’s help dam those wires are tiny . Of course I had to do it twice due to wire colors not matching and me trying to guess . Glued and taped that arm back in place . Did a factory reset, struggled with calibration . Still think my compass maybe off . But after failing to be able to do rotating calibration due to no progress bar ever showing up , quick calibration got me airborne again flew well from then on maybe about 50 or 60 nice 6 to 9 min flights . I stopped trying to use tower or the sky viper app and fly mainly Los with the web 192. … interface . Its only been last few weeks ive tried to use Qground or tower again , no longer get bad loging error but Tower app crashes Q conects but wont upload more than one way point. Last weekend I noticed rear motor starting to fail started getting ground mag errors as well and video got super jello . Started motor replacement . Dam those small wires and my shakey hands . .Surprise wife tells me she ordered a new 2450 gps online will be here . Sometime before 8 June so I’ll just see if starting from scratch solves my problem Thanks Cathy !,

When you first connected the app it should have been updated (you should have gotten a popup).

The bad logging thing, I think, was a software bug but didn’t affect performance.

Your wife is great! Mine just bought me a Nintendo Switch, which works because my 6 year old can’t fly drones with me yet.

Also, she shoulda waited till the Journey was released lol Of course that could still be a few months…but hopefully not.

1 Like

Tower worked this morning! Full Auto mission. Parameters as shown above. .

1 Like

That’s good to hear , I wonder did Tower app get an update ?

no it hasn’t been updated in over 6 months i think. dev doesn’t work on it anymore. Or dronekit-android which it uses. I made a PR against it trying to fix follow-me, and it is just sitting there.

1 Like

If anyone knows the SkyViper folks and they are interested in sending me one I can look to see what is going on with QGC and mission uploads.

1 Like

Don I would consider sending you my flight board and sonic , to check out. But I wanted to see if I could transplant those in to a frame with matching props and gear mounts and 8x20 brushed motors , I’ll post a pic of quad I’m talking about got it in 2014 for around $50 cdn.adding photo https://www.facebook.com/photo.php?fbid=10157253320004937&set=pob.549259936&type=3
One in upper right corner . Is a good stable flyer , motors getting weak though and range is sketchy beyond 50 m

1 Like

New viper has arrived . I now have 4 1200mah batteries whoohoo! Now to see if I can get a mission to work

Auto-mode missions are working pretty well in Tower. Parameters are as posted above. Flight distances from Home far exceed the range of manual flights. Still experimenting with Actions (camera trigger etc.) but it flies and the Tx camera/video buttons work, so that’s a start. Next, back to experimenting in Q…

Update , I was able to get Tower on Android conected to Skyviper at last . Seems what I was doing wrong was turning on the controller /tx . That must be off . Not sure why that is but it works.
Also new viper arrived had a bad pinion on one motor looks like a quality con troll issue teeth never got formed on part when molded or milled how ever they make them little nylon gears . Thankfully good pinions on my broken frame so shaped oout.

@OlivierB I’ve started testing with the SkyViper you sent me. So far I think it may just be that the WiFi link is really noisy which in turn causes the Mission protocol to fail. Still looking…

Another question: Has anyone gotten the video to play through to QGC?

1 Like
Servers by jDrones