Q Variables Descriptions not visible in Mission Planner Parameter List

I loaded 3.5.2 and noticed that descriptions for the Q variables and valid values are not listed in the parameter list in Mission Planner. I thought I had seen them in 3.4. Is there something I need to do to make the descriptions and valid values visible?

Hi Mark,

Were you able to find how to get these two columns to populate? I am having the same issue.


Did you solve it? We can’t see any Q variables. I know you can set Q_ENABLE to 1 to show the other parameters, but we can’t even see Q_ENABLE

Update Mission Planner to latest Beta?

Did that. Just to make sure I uninstalled then reinstalled. Thanks for the thought though!

Re-install won’t install the latest beta. You have to do that from the Help screen, button on lower right. Did you do that?

Post your parameter file. I just checked this with 3 different flight controllers I have on the bench, one a Pixhawk, an F7 board and an F4 board and they all show Q_Enable.

Ok, installed the latest beta (there were things that needed updating, so thank you for pointing out the difference). Still no Q_ENABLE. This is the .param file we (Ashley and I) are trying to use. GregsMiniTalon_AfterNewMotor.param (17.0 KB)
We are using another’s .param file because we are so new to this and we’ve been having some problems. We thought we would start with his .params and then try to write our own params/tweak his later.

Did you load Greg’s parameter file using “load from file”? If so that is not advisable. You should probably reset to default and then use the “Compare Parameters” function in Mission Planner and update each parameter manually. Tedious maybe but loading another parameter file can cause problems between Flight Controllers and revision levels. They should only be used for reference.

Ahhh, ok, we’ll give that a shot. What happens if we set to default and there still isn’t a Q_Enable param?

No explanation for that. Reflash Arduplane. But if so post a screen shot like this after connecting with the FC. Messages tab showing.

No Q_ENABLE. We reset to default, the pixhawk rebooted, we reconnected… nothing. The first pic is just showing you we have no Q params. Second pic is the one you requested.

Also, thank you, thank you for all your help! We’ve been stuck for a while.

OK, the top of the sceen capture is cutoff so I can’t see what’s there that but it looks like it’s showing quadrotor firmware installed. Also, the valuable info in the messages screen has already scrolled by when you made that capture but the messages “check firmware or Frame_CLASS” is telling.

Flash Arduplane to the Flight Controller.

Is this what you are looking for? The Frame is unknown?

See this here?


You have Multirotor firmware installed. Quadplane is PLANE. Then you wrote a Plane paramater file on top of it. No precedence for that, never heard of anyone doing it.

Load Arduplane firmware.

Oh my heck, that solved our problem. Thanks a million!!! We now have our “Q” params! Thank you thank you thank you!

I still don’t suggest that you load someone else’s parameter file for any reason. As you found out it will do it even between completely different vehicle platforms. Compare parameters or even handier is a text file compare application. I use this one:

yeah, we are going through our parameters now, and have found some that will need to be altered because we are using different electrical components than he is (like the type of ESCs and such)