Pymavlink "BAD_DATA" error with companion computer

first of all, I should say I’m beginner at pymavlink and don’t know about it errors.

I Used pymavlink with my ORIN NX to connect my CUAV Autopilot.
It can detect Heartbeat but after this, gives “BAD_DATA” error.
first I used this config :

after that config doesn’t work I try with 115 baud and still not working.
Then I try with SERIAL2_PROTOCOL = 1 , with 57 and 115 baud but still gives me “BAD_DATA” error.

I attached my code and terminal outputs photos.

Can anyone help me?
@amilcarlucas @ppoirier @rmackay9

Regards, Joe


THS0 implementation is shitty, I suggest you connect to a FTDI dongle (USB0)

thank you for your reply.
I haven’t FTDI, but also tried with USB to TTL, convertor and I have same problem.

You have connected Ground-Tx -Rx between CC and FC ?

And also manually disable flow control for serial2 in full parameter list.

Try installing mavproxy on ORIN and test connexion using mavproxy console just to make sure this is not a hardware issue.

As you said, I install mavproxy and test with that.
But I have “link 1 down” error!

I use HIL firmware for test some commands. Does this affect the result?

Looks like you have conflicting apps accessing the port

If you work with USB dongle it should cause no issue
Otherwise you may have not disabled the console to THS0