PX6 Support - unable to load firmware

just received my new Pixhawk 6X.
But appears it is not supported yet as I’m unable to load any firmware. In QGroundcontrol there is no firmware listed for Arducopter, only Pixhawk 1.13.0 showing up and I can load that across.
Tried also MP - no success. - Both mentioned GC’s running on Linux. (Ubuntu 20.04).
So I tried Windows7 instead: "USB device not recognised " coming up initially and then spend hours looking for the PX4 driver which apparently is suitable but all links are no longer working.
Finally found a workaround which accepts the driver as a USB serial device, but MP doesn’t find it under Windows7.
Any ideas ?
…or is it a matter of having to wait until a new driver / support becomes available ?

Update: Have found an entry regarding similar issue on earlier Pixhawk Version.

Tried uploading firmware in that way but got a message: “Firmware board ID does not match hardware board”

Did you try downloading the .APJ from here and using Mission Planners “load custom firmware” option?
Pixhawk 6X

1 Like

Thanks Dave,
I’ve tried to find that version but all I came across was the PX4 file.

Did it work?

Yep, just finalised upload.
No idea why I’ve missed that version.
…but do you happen to know if the firmware upload function is actually supposed to work with those FC’s ?
Thanks again

Very new stuff so no, not sure. If the board isn’t recognized by QGC or MP then it won’t find a target. But it is only in Master/Latest.

Unfortunately the joy was short lived:
Whilst the .APJ firmware upgrade worked, I can not connect with MP or QGroundControl to it.(under Linux)

However, in APM (also Linux) it will connect and show response in the HUD to basic sensor input, but can not upload frame-type or do the basic settings as “Unknown autopilot cannot fetch firmware versions” message comes up.

In Windows 7 I get a driver related message, …so can’t even connect / MP can’t see it.

…So I’ll guess I just have to wait until full support is released.

Huh. It’s supposed to be identified as board 53:

board ID for firmware load

Looking at the Holybro site when you click on the Ardupilot firmware link for the 6X it opens the 6C directory… I suppose the PX4 flight stack works? Drinking the Drone Code cool-aid :grinning:

Gotta love technology,…
With the original PX firmware - at least after updating to 1.13.1 - I could connect under Linux with both MP and QGC.
Then I used your suggested link for the Pixhawk 6X and using the .APJ file the firmware upgrade worked…but then had the before mentioned issues with board not being recognised and hence unable to do anything else with it.

Now I had a look at the Holybro docs regarding the latest firmware support:
I tried their suggested link for Pixhawk 6X but end up with files linked to the 6C !
I thought I’ll try it and then this came up:

So, then I decided give the other recommendation a go: " Must use “latest" Firmware at the moment” by just using the developer option in Firmware upgrade section. This worked but once again same issue as before that I can’t connect in a way I can proceed any further.
However, the status LED now works (flashes) on the GPS/switch unit which didn’t work with that version you earlier suggested.

…might “go on holiday” until full support is released.

Update: Discovered that I can connect to the 6X via mavproxy and it will show up in both MP and QGC.
However, message about problem with gyro keeps coming up despite attempts to calibrate and also issues with compass calibration.
…wouldn’t attempt to fly with it like that anyway for now.

The latest on the 6X front:
( All using Linux and the developer version (latest) for the 6X)

The good:

  • Can connect with both MP and QGS (daily build)
  • Both my GPS work as expected
  • The HUD responds as expected
  • Been able to upload my saved settings from previous FC (but expect will have to do all tuning again)

The bad: (I assume all due to current lack of support)

  • Gyro calibration keeps failing
  • Compass calibration sometimes appears to work but on next reboot of FC asking for calibration again
  • No voltage & current displayed from PM (assume digital system not supported yet)

The latest on the 6X front:
( All using Linux and the developer version (latest) for the 6X)

Today I’m please to report that now the battery monitor (digital) works and provides correct values.

However, when arming a fault popped up immediately: “Warning Terrain: clamping offset 16 to 15”
Turns out for some reason TERRAIN_ENABLE and WPNAV_RFND_USE both where enabled for no known reason.
Anyway, disabled both and appears fine now.
PS: Not attempting to fly yet. …just testing.