PX4 with S8R for quadcopter/drone

Hi , I’m start build up drone using tarot 650 and px4 (H) with receiver s8r ( is for fixed wings) using Sbus port , I don’t wont to cut wire of ese and soldering it with PM so I connect it with FMU PWM in with I/O PWM out in FC, I tested all motors induvial and ese and all its work , radio celebration its work , when connect esc directly with receiver motor working well , but the problem when I do motor test in mission planner message test come also when I tray moving it by TX its clear the ESC its working and give sound but the motors still not working ? so please help me what the problem now ?

  1. The 4 ESCs are connected Main Out pins 1,2,3,4?
  2. Does the ESC have a Built in BEC?

Post few pics, Show your complete wiring diagram and provide specs of ESC and other details.

yeas sir … the esc are connected with 1234 inn PM … and I/O PWM IN PM connected with I/O pwm in FC

Ok, next when you go into Mission planner, I am assuming you have done ESC calibration using this method https://ardupilot.org/plane/docs/guide-esc-calibration.html

If not make sure you do ESC Calibration.

Then do each motor test. Note flight mode settings required.

HI sir, I have to try follow all these steps but the motor still no move and ESC not stop beeping( continuous beeping )

Continuous beeping usually means there is no throttle signal.

so , what i should do ? cuz radio calibration is working well , but there is no throttle signal.
whats the wrong things please help 2 solve this issue

Post your parameter file maybe something is obvious. And you have a real mess of wires, can you post a better photo showing just the Power Distribution Board?

magdrdone55.param (17.6 KB)

i hove its clear pic , thank you a lot Mr, Dave

You have Plane functions assigned to the Servo Outputs. I can’t imagine how that happened but I think you should start over. 1st, can you post a screen shot like the one shown below showing the version of firmware you have installed? Connect to the Flight Controller and select the Messages tab so it will show the version of firmware you have.

OK, at least you have Arducopter installed. I think you should reset to default and start the configuration over again as you have a real mess with the Servo Outputs and I would worry there is more amiss. Navigate to the screen and press this button:

Everything will be reset as if you just installed the firmware and you will have to configure and calibrate it again. Start with Mandatory Hardware and work your way thru it from the top.

HI sir , now motor test is working well but still motor not spin when i move throttle stick, when i press safety switch in gps , all beeps stop and for gps FC led come green ( so motor test is working well ) are there some parameters i need to define it like servofunaction orRCmap? …

Are you arming after pressing the safety switch?

do you mean by arming move the throttle stick , if u mean that yes i pressing the safety switch and i move it

If it’s arming there should be log files. Post a link to the last .bin log file on the flight controller.

2020-04-18 18-09-34.tlog (308 Bytes)