Hi, I just have a problem about flow of UAV. in Guided or Loiter mode, the MP always warning:NO POSITION ESTIMATE!
there is some basic parameters i set: EK3_FLOW_USE = 0;EK3_GPS_TYPE = 3(NO GPS);FLOW_TYPE = 6(UAVCAN);EK3_ALT_SOURCE = 1(USE RANGE FINDER)

Which firmware version. Can you post a .param file and a .bin log file?

1 Like

Thank you for replying!
I use this one:https://firmware.ardupilot.org/Copter/stable/Durandal
Now,I have basically solved it by changing EK3 to EK2. it works now.

You still did not answer my question. I asked what FW version, I did not ask which hardware version.

1 Like

ok,do you mean this one?

The firmware version also contains a “git hash” code that gets printed in the messages window every time you boot. Like this:

APM: ArduCopter V4.0.7 (32a80370)
APM: ChibiOS: d4fce84e

That 4.1.0dev might be very outdated. where did you get it? when did you get it?
Can you update to 4.1.0beta6 ?

1 Like

I got this version LAST DECEMBER from https://firmware.ardupilot.org/Copter/stable/Durandal
my supervisor thinks that the beta version is unstable.So we don’t update it.

Funny. The Dev version you are using has everything from Beta plus a lot of other features not thoroughly tested.

1 Like

I’m sorry, I’m confused with these pictures. This is the version we used before.
4.1.0-dev is the unstable version from Last December.

Anyway, I’ve solved the problem, thank you! :grinning:

So how many version type exactly there are?dev,beta and stable?
what is the exact relationship between them?

Stable-Full tested, current official version.
Beta-Added features and fixes that are tracked in the Changelog. Testing phase but generally Stable.
Dev-Development of new features/functions. Not necessarily Stable, some risk.

1 Like