PX4 Main output don't map correctly


The main outputs of my pixhawk where I have to connect the 4 ESC’s of my quadcopter to, don’t map correctly. Basically the channels setup on my Taranis are just passed thru. On main output 1 of the PX4 I have channel 1 of my Taranis X9D Plus, on main output 2 I have channel 2 etc. Firmware installed is Arducopter v4.0.3. I am using mission planner 1.3.70. Using a X8R receiver.
I would very much appreciate if someone could help me out here.

Best regards

Why would you passthru channels on a quadcopter?

I don’t want them to pass thru. I just see that is what is happening . I want the outputs to be configured like it should be (i.e. throttle to go to all 4 outputs) but don’t know how to do this. Do you have any clue?


Little confused about your post:

TARANIS Setting:

  1. Select a new model. Taranis will automatically assign the following channels.
  2. Inputs: 1 should be Aileron “or” Roll for your quad.
    2 should Elevator “or” Pitch for your quad.
    3 Should be Throttle
    4 Should be Rudder “or” yaw for your quad.

Above are standard settings. i am assuming you know how to bind the Rx and all other cool stuff.

Now connect taranis RX via S-BUS to PixHawk. the S-BUS port on Pixhawk is RCN port “NOT” the one marked as SBUS. The bottom pins are signal pins.

On the pixhawk your ESC should be wired this way. I am assumign your ESC have a built in BEC. Double check that.

Use MAIN Out Port on Pixhawk only for a quad.


ESC 1 “or” Motor 1 connects to Pin1
ESC 2 “or” Motor 2 goes to Pin2 and so on.

Notice below which motor is marked as 1, 2, 3 and 4. Must conenct ESC wires correctly to PixHawk.

Connect to Mission planner while props off. perform ESC calibration FIRST.

Follow these instructions.


Make sure put props correctly. means clock wise props goes to motors spinning clock wise.

Do you have a PX4?

Above instructions will work, but off course wiring will be different.

Are you using this board?

All PX4 Information can be found here.


Well sure I have a clue but it’s all in the Wiki. Start here:

1 Like

Hi all, thanks for the response. Let me give some more info. I went thru the complete setup without any problem. Connection between the transmitter and RC works fine. Got all the correct channels setup as it should (Roll, Pitch, Throttle and Yaw) and I see signals come thru correctly on as well the "Radio Calibration’ tab as the “FailSafe” tab. The problem I have is to map the inputs to the correct outputs (“Servo Output” tab). Apparently all functions are default set to RCIN1 - 8 which means that the inputs are just passed thru to the outputs. I have been changing the functions of the 1st 4 channels to Motor1 - 4. I see that the output signal (green bar) moves back to about 10% for these first 4 channels and would assume now that if I move up the throttle that the output signal would move up (green bar) as well. Unfortunately it is not happening. I have isolated the problem and think I am not far from a solution but somehow can’t fix it. Any help is welcome!

The inputs are not passthrough to the outputs. The Flight Controller would serve no purpose in that case. If this is a quad and you have chosen quad X (for example) as the frame type the default channel mapping will work.
SERVO1_FUNCTION=33=Motor 1 main out 1
SERVO2_FUNCTION=34=Motor 2 main out 2
Connect Motors to the main outs 1-4 with respect to quad X (for example) motor order. Then run Motor Test in Mission Planner to make sure you have the physical connection to the right motors and the prop direction correct. Put props on and fly it after doing the mandatory calibrations.

Forget about trying to do bench testing of motor outputs with your radio, it’s meaningless.

Hi Dave,

Reinstalled everything from scratch. Checked SERVO1_FUNCTION and values are correct (33, 34, 35 and 36). When I try the motor test I get message “Command was denied by the autopilot”. Does that mean anything to you?

Many thanks

Do you have a safety button? Pressing it? Or just Disable it as it’s an annoyance and of questionable value on a multirotor (IMO). Set BRD_SAFETYENABLE to 0. You can set it back if you like after getting these basics done.