PX4 Flow Sensor with Pixhawk 4 not working in I2C A port

Hi all,
I’m using PX4 Flow sensor with Pixhawk 4 hardware.
My configuration is

  • Arducopter V3.6.7
  • Pixhawk 4
  • PX4 flow sensor @ UART & I2C B port (only SCL & SDA)
  • Optical Flow enabled
  • Power to flow sensor is provided separately from 5V BEC

I’m getting non-zero values for “opt_m_x, opt_m_x & opt_qua”.

I wanted to connect the same in “I2C A” port. So I changed from 6 pin connector to 4 pin connector. There is no values for “opt_m_x, opt_m_x & opt_qua”. I changed back to 6 pin and connected in UART & I2C B port and everything is working same as previous.

Anybody faced same issue??
What can be the reason??

Thanks in advance.

Hi there,

I just signed up for the Ardupilot discourse - it’s been a long time coming. I’m having a similar issue, so I thought I would touch base.

I’ve been trying to connect the PX4FLOW and A TFMINI Pro to the i2c A port. I recently updated he firmware from Pixhawk to Arducopter - at one point I had the PX4 flow ‘sort of working’ on the i2cA (it seemed unreliable, worked part of the time.)

After updating the firmware, I cannot get data to work through i2c A on either device - tried one at a time, also I tried separately powering the i2c splitter using clean 5v - no luck.

My current situation: Partial solution - connect the TFMiniPro Lidar to the UART/I2C port as a serial device. Data/readings work.

Still in the weeds on the PX4FLOW.

Have you made any progress on this front?

Thanks,

Ben

Quick Specs:
Ardupilot 4.0.3 installed on Pixhawk fmuv5
PX4Flow-KLT firmware installed on the PX4flow
(https://download.ardupilot.org/downloads/wiki/advanced_user_tools/px4flow-klt-06Dec2014.zip)

Side notes:
Mission planner does not show dropdowns for Rangefinder or Optical Flow checkbox; even when the lidar rangefinder is connected and working.
Mission planner ‘focus’ button does nothing when connected to the px4flow via usb (I also tried setting usb stream video to 1.)
Q-Ground Control does allow me to connect to the px4flow and focus the camera, so I know it’s not that…

Hi,
I also have the same problem. have you fix the issue with PX4 flow sensor?

Thanks

Perhaps this will help a bit.

https://www.youtube.com/watch?v=ChLsO4zIS2k&t=1s