Servers by jDrones

PX4 FLOW driver for Windows 10


(Conrad) #1

I have got my new Pixhawk unit two weeks ago and spent a few hours on 3 separate computers in the house to try and get it to connect via USB cable. I used multiple cables, powered the Pixhawk direct from the USB port, powered it from an external lab power supply (12.0v, pulling 0.2A), I tried this on two separate Windows 10 PC’s…to no avail. I followed this procedure exactly:

https://pixhawk.org/users/px4flow_windows_driver

However when I connected the Pixhawk via USB (after I installed the Mission Planner software as well as the USB drivers), I don’t recall the exact error but it would list it as a USB device that was unrecognised. So I tried to manually update the drivers with the PX4 Flow as shown in that tutorial, all I’d get is a USB to Serial A…B…C…D option and nothing that would be PX4 Flow. So I tried every option listed and always got a small exclamation mark in the Device Manager window and it’d never list a COM port.

After struggling with this on two PC’s, one being a laptop that I plan on using MavLink on, I thought to try it on a Windows 7 machine. Plug it in via USB with the same 12v external power supply, once connected the device shows as a COM port…and is shown as PX4 Flow. I can’t believe it. So is there an actual Windows 10 driver that works with the Pixhawk? As I’d like to have a single laptop (Windows 10) that can fully control, monitor and update my automated boat and not have to rely on a Windows 7 machine that is in my garage at home.


(ppoirier) #2

Hello
Just to let you know that I am working to simplify this painful process


(Conrad) #3

Fantastic!

I have kept that Windows 7 PC unupgraded for instances like this and I’m sure glad I did! Now the new Rover firmware is out so I’ll be off to the Windows 7 machine to upgrade it again!


(ppoirier) #4

In the meantime, using the px4 drivers https://pixhawk.org/users/px4flow_windows_driver
and QGroundControl for flashing (under firmware - custom) works fine on Windows10


(Mike Boland) #5

Is there any update on this?

I have a Pixhawk4 and I am getting the exact same issue as described here.
I tried your link for the px4flow driver but it is broken.

QGC and MP do not load a driver, and APMP does not recognise the board so will not load a firmware.
The PH4 apparently comes pre-loaded with the PX4 FW but I want to load Ardupilot.


(ppoirier) #6

Hello Mike,
I think this page moved here: https://docs.px4.io/en/sensor/px4flow.html
And I have read about the Pix4 here :https://github.com/PX4/Firmware/issues/10106

Patrick


(Anthony Johnson) #7

This link to drivers does not work says oops. I have this same problem the pixhawk and qc or MP are not talking as the pc software says you are not connected. I have also tried on two windows 10 machines and the cable is well tested and works with pi no problem. I am sure it must be a driver issue but cannot even get to the part of firmware as both apps say your not connected. Now I am as with no battery attached the pixhawk lights up from USb. But with or without external battery (I am using lipo 2 cell) same problem.


(jack douglas) #8

I am experiencing same issue with no COM port recognized due to bad Win 10 driver. I attempted to install the unsigned driver found here:

http://download.ardupilot.org/downloads/wiki/advanced_user_tools/

but no luck. Was hoping to enjoy the experience but ready to send it back to the seller.


(cbrk1) #9

I gave up on getting it to work on Windows 10. Instead I used a linux VM and installed QGC on it. I was able to get it working in minutes and was able to focus the camera. Both the normal mode and the HD mode (to focus it) worked well. No special drivers were needed, it just worked. Now mounted and tested on my copter :slight_smile:

@jax200 I’d take that route rather than send it back.


(jack douglas) #10

I did finally get it connected and focused using Mission Planner with Windows 10 on another system. However I am having issues with getting Flow data (“bad flow health”).

I am also trying to get it to work on a Linux system with QGC but keep getting errors with QGC install. I’ve tried different distros.


(Tolga) #11

I do also had oroblem with win10 as it doesn’t recognize the px4 board but on linux board it worked flowless. The wiki was written based on mission planner and with qcs parameters are not the same. So i couldn’t do the sensor calibration as it is indicated.

So i will give a try with qcs and fly the copter and see how it goes.

It seems not many are using px4 optical flow.


(jack douglas) #12

Hi Patrick

Recently, I started poking around with the PX4Flow as a learning experience with my hexacopter. I am not an engineer (I’m in biological sciences) but keen on learning as much as possible about coding, circuits, flying,etc. I have the PX4Flow installed and sending data, but now changed my I2C address with the jumper so as to accommodate the GPS, hence now no longer getting data. I have no idea how to set the new address in the code. Possible to provide guidance?

Cheers

Jack


(ppoirier) #13

Hello Jack

Take a look at this
http://ardupilot.org/copter/docs/parameters.html#flow-addr-address-on-the-bus

So depending how you changed the address by soldering the bridge you hsve to add the offset from 0 to 7


(jack douglas) #14

Many thanks Patrick. I soldered 0 and 1 and used address 0x45.

I understand one must also send a terminal command to the FC? Is this sent prior to each flight?

px4flow start -a 0x45  

Jack


(ppoirier) #15

You go in Mission Planner and set the parameter FLOW_ADDR to 03


(jack douglas) #16

Yes I did that. I wasn’t certain if this was something more.


(shahar) #17

Hello, I am looking for the driver but can’t find one.
this link is broken.
on another link I have found I am prompted to download a ZIP file, but all it contains is an INF file which did not help me.
is there some driver I can use ?
Thank you