Servers by jDrones

PX4 Flow Bad Health Problem

(ppoirier) #6

Just be aware that the firmware is different for px4
On Ardupilot the PX4Flow is running the KLT algorithm and on the px4 its the SAD algorithm

(Gunter) #7

Ah okay,
so that means if I am using QGC for installing the FW for the Flow Sensor it will defently not run with Arducopter? Because I tried to reinstall the FW with Missionplanner for the Flow Sensor. But it doesn´t work because the FW was already installed. So I used QGC to reinstall the FW (but the File was the same as with MP). I will give it another try and set it up with MP and APM Stack.

Is there a way to force a reinstall of the FW with MP? It tells me always the FW is already installed, there is no Need to update.

Thank you!

(ppoirier) #8

Good catch here !!.. Its been a long time since I updated my units, I will give it a try

Ok I remember == You go in QGC and load a custom firmware click ok and select the KLT

(Gunter) #9

Yes, exactly how I did it. I am still running the KLT FW. So it should work with ACopter. I did the reinstallation with APM and got still the Bad OptFlow Health :frowning:

(ppoirier) #10

APM ?
Are you using Mission Planner?

(Gunter) #11

At the Moment yes, I just Installed Arducopter 3.5.5 with Missionplanner again to give it another try. I dont know which Ground Station and which flight stack I am gonna use finally . I would prefer to Work with Missionplanner because of better documentation and nice Support at the Forum :-).

I did the reinstallation of the FW for the Flow Sensor with QGC.
And before I tried PX4 with QGC to see if the Flow Sensor would work with this workchain. But finally I reinstalled APM with Mission Planner again.

Right now the System reconized the flow sensor. Will see if it does it again.

EDIT: I think right now it is a matter of if I am plugging the USB in while it is booting up or not.

Thank you!

Unable to get response from px4flow
(ppoirier) #12

Make sure that you supply the Px4Flow with a good power source == All my builds use a dedicated UBEC and Capacitors for px4flow and RangeFinder.

Please note that I opended an issue with Mission Planner Firmware flashing . Its not working correctly, the method with cusrom firmware using QGC (as showned above) is working better.

2 Likes
(Gunter) #13

Good morning from Germany,
Okay how could the supply Looks Like? At the Moment the Flow Sensor only gets Power via the pixhawk. I could supply the Flow Sensor with 5V via USB by a PDB. I will give IT a try.
The rangefinder already does have a separeted Power supply by the I2C Adapter (teraranger one).

Thank you!

(ppoirier) #14

Hello
You can use the same UBEC for both the rangefinder and the opticalflow

(Gunter) #15

Hi,
it seems that it is working, thanks o lot! To supply the PX4Flow in additional with Power should be a item in the wiki.
I cut off a USB cable and did some soldering on it to get the 5V to the USB Port of the Flow Sensor. Is there a different Option to supply the the Flow Sensor with Power? For example to solder some cable straight to circuit board of it?

Thank you!

(ppoirier) #16

Hello
I feed the power from the I2C directly
Cut the vcc line from the Flight Controler and inject power to the I2C hub from the UBEC (and common ground)

2 Likes
(Gunter) #17

Hi,it seems to be great success :slight_smile:!

Thank you! Did it the way like you, put the +5V coming from mit PDB to the I2C Hub.

(ppoirier) #18

Cool = Hit the like button and set status as solution found so other can their optical flow working
Dont forget to follow through the config and calibration and Enjoy the Fly

(Gunter) #19

But now I do have some Trouble with the Range Finder^^. It a TeraRanger One, it just appeared since I did the Power Supply via I2C Hub with PDB. It says “Prearm: check Range finder”, and in the initial Setup the Range Finder don´t give some values. Just tried with the supply via Pixhawk, now I do have values again, but the prearm message is still there. There is no Change if the TeraRanger one get power at first.

Is LIDAR the same as Rangefinder? Because if the TeraRanger is not connected and he aspect the LIDAR he gives me the BAD LIDAR Health. But ir is gone if the TROne is connected. But I always do get Checke Ranger Finder.

Thank you

(ppoirier) #20

Hum… I’d like to see a picture of the setup

(Gunter) #21

Here is a Little drawing how I connect it. I disabled the Parameters in Prearmchecks. I think the check Rangefinder is coming from the Sonar from the Flow Sensor, caused by to Little distance to the ground?!

At the Moment it is working, after connecting the LiPo I reconnect the Powersupply to the Pixhawk. After that the Flow Sensor is running.

Thank you!

(ppoirier) #22

Make sure you have ground continuity (common ground as I wrote above) , so in the diagram below I added ground from PBD to HUB, assuming that both 5V and 12V grounds are connected together on the PBD

(Gunter) #23

I measured between Ground of Pixhawk an Ground from PDB. There is a clear Connection so they should have the same Ground.
Yes 12 and 5V does have the same ground.

(ppoirier) #24

Hoho just saw that the Tera I2C is fed with 2 supplies :slight_smile:<img
Can it be supplied with 5 volts or it requires 12 volts asolutely?

(Gunter) #25

Yes, you have to use an Adapter with 10-2x V supply. They do have the same ground Connection.

But I think I got it now. I have to make sure that the Opt Flow and TR One do have at first power. Mostly it works, sometimes I do have a bad Lidar health message.

For General, if there appears a Bad… Message, and after a second or two it vanish at the flight data screen. Does it mean that everthing is fine then or is there still a Problem?