Proximity setting caused attitude failure

Hi to All,

I am writing about a strange problem, I have faced with during this summer.

My setup:

Micro Pix (this kind: with Copter 3.6.10, ChiBios
Modified F450 frame with shortened and carbon fiber tube arms. Wheelbase ~390mm, Copter setup: X
SunnySky 2212 KV1400 brushless 4 pieces, with ZTW Spidet opto 30A ESCs
10*45 carbon fiber props
7000mAh 3S LiPo battery
External m8n GPS/compass, LidarLite V3 I2C, Maxbotics sonar I2C.
All calibrations has been made before flight.

Symptoms: The craft was set up to use the lidar as altimeter and the sonar as backward proximity sensor. Proximity settings were made to avoid the obstacles in 2 m range both in GPS or non-GPS situations. On ground it was functioning, arm check failed if anything got near to the back of the copter.
In air, the copter was fairly flyable in Stab. mode using the previous PID settings (set before the lidar was installed and the proximity settings were made), but it was much unresponsive than previously. In AltHold, it actively banked forward, about 8-12 degrees, and started to fly away if no RC countermeasure was made. In PosHold, it got leveled again, but it was nearly out of control, responses were extremely slow, even in case of setting the “Roll/Pitch Feel” and “Roll/Pitch sensitivity” to the extreme crisp end… It flies sluggish as hell… In Loiter the things get even worse, the craft is out of control, and crashed many times…

Solution trials: motors checked, all are running at the same speed at the same PWM (confirmed by contact tachometer). ESC-s checked, all give the same outhut to the same PWM input. FCU PWM output checked, no problem. It seems an internal setting/software/hardware problem, so I bought a new FCU (same type), replaced the original and set up the parameters by hand, nothing loaded from the previous congiguration. Everything checked again, and again.

Result: Same unresponsiveness and tilt error in AltHold has been experienced again.

Solution trial part 2: Since the error started after installing the Lidar, I killed all the lidar, sonar and proximity settings and tried to fly. Miraculously, the craft has flown perfectly, crisp (even too crisp…) responses to RC inputs and fast leveling was experienced in Stab, Althold, PosHold and Loiter modes.
So, I re-plugged the Lidar and also re-enabled it in the parameters, and flown again. Again, no problems.
Re-plug/re-enable the backward facing sonar, and fly again. No problem.
Re-enabling the PRX settings. AND the sluggish behavior started again! I do not even dare to try Loiter, Stab was flyable, but AltHold was tilted (actively!) and PosHold was sluggish as hell.
Switching off the PRX setting (“PRX_ Type” set to “none”) restored the flight characteristic OK again.

I enclose logs with PRX on and PRX off as well. What kind of setting could improve the situation to use the PRX feature and get the craft flyable in the same time?

Thank you for your kind help in advance!

Sorry, the naming of the logs was mixed up, Log_25 is PRX ON and Log_26 is PRX OFF.