Problems with NMEA 0183 GPS input

Hello,

I am new to the community and ArduPilot/ArduRover in general so please forgive any ‘dumb’ questions. I am working with ArduRover on a CubeOrange platform to be used on a boat platform. For this application I need to interface to a GPS with NMEA 0183 or NMEA 2000 protocol output. I am currently working with a Garmin 19x GPS with NMEA 0183 output.

Using Mission Planner I have configured GPS_TYPE to 5 for NMEA. I confirmed SERIAL3_BAUD is set to 38 (38400). GPS_RATE_MS is set to 100 (10Hz). Using Garmin tools I have confirmed the Garmin is configured for NMEA 0183 at 10Hz 38,400 baud. I have wired this into GPS 1 (and tried GPS2) and confirmed with a scope that the Garmin is outputting data at 10Hz at logic levels of 3.4V. This appears to be valid voltage inputs for the hardware (3.3-5V spec). This output from the Garmin is wired to the GPS pin described as RX for AP (but I also tried swapping RX and TX).

My problem is that with this configuration I see no indication that the GPS position is being received by ArduPilot. When running Mission Planner my current position is shown as 0.0, 0.0, parked off the west coast of Africa.

I would appreciate any suggestions on what I have done wrong or am missing in the configuration to allow me to get this GPS signal in. FYI, although it looks like NMEA 0183 is preferred on ArduRover, this device also can be configured to output NMEA 2000 protocol alternately.

Thanks for the support!