Problems with airspeed and Elevon


I’m doing several tests with I2C Airspeed and I’m with a behavior I can’t explain.
After the boot and warm up before enable airspeed the elevons was always flat. Now after I enabled, flight and calibrated the Airspeed the left elevon is always 20 degress ± up and right elevon is flat.
This is the expected behavior for auto/fwb flight modes ? If I change to manual mode both elevons are flat.
I was debugging this and is the controller sending a pwm pulse over the mid servo value. I calibrated several times accel and gyros and the same behavior is happening, if I disable the airspeed the elevons are flat too.
This is the manual mode pwm:

And this is on auto mode:


What happens if you switch between MANUAL and FBWA mode?

If FBWA causes the deflection that you see, try 2 things:

  1. send roll commands via your TX. Do the ailerons move as desired?
  2. physically roll your plane from side-to-side. Do the ailerons “do the right thing” to counter the roll?

If FBWA does NOT cause the deflection, but AUTO does, let us know that too.

Hi @hunt0r,

In fwba all movements are ok as expected. In fwba the elevons are level.
In auto mode, all movements are ok except the pitch down is not working - I think maybe is because the the left elevon is up.

If FBWA works as expected, both when you attempt to command roll via the TX and also when you roll/pitch the plane, I think that verifies your Elevons are set up correctly.

Someone else could chime in… my guess is that in AUTO mode, the strange elevon behavior you’re seeing is some combination of attempting to steer to the next waypoint, and also being held safe by some logic checks designed to prevent accidental on-ground automatic behavior.

I am not sure what any of this has to do with the airspeed, or the I2C airspeed sensor. Am I misunderstanding something?

But why just when airspeed are enabled?
I’m updating to 3.8.2 - currently I’m using 3.7.1.
I realize while airspeed are calibrating and there is no 3dfix the virtual horizon is oscillating but after 3dfix is everything normal.
I don’t think is related to waypoints because the plane are on the ground and the first item is takeoff - and if I disable the use_airspeed the elevo works fine


Can you post a .bin Dataflash log which captures the issue?
I think AUTO and FBWB, which control airspeed, may have some interaction with the existence of the airspeed measurement.