Problems when installing the new firmware

For some reason I can’t upload new firmware using Mission Planner
I previously installed 3.6 rc2 firmware, and everything was fine


This means that the MP doesn’t recognise the bootloader on the board maybe because the ChibiOS firmware was uploaded to the board and the MP hasn’t been updated in a while… so it’s an old version that doesn’t recognise the ChibiOS bootloader.

I think the solution is to try updating the MP to the latest version (Go to the Help and push the “Check for Updates” button).

If updating MP doesn’t work then I think the next solution is to manually download the appropriate firmware from and then use the “Load custom firmware” link on the “Install Firmware” screen to load it to the board.

If you’re using a board from the Pixhawk family and want to stick with the NuttX based firmware (i.e. the operating system we’ve been using for ages on the Pixhawk) then download and upload the “ArduCopter-v3.px4” file found here.
If you want to load the ChibiOS firmware to a Pixhawk familiy board then there are instructions here.
If it’s one of the new drone racing boards (aka ChibiOS-only boards) then we have instructions here.

Hope this helps…

1 Like

I’ve had some strange behavior here as well, switched to Q-groundcontrol for uploading firmware, did not have a single issue there.

That’s what I have done to go from a Chibios install back to a Nuttx rev, use QGC. After that configure in Mission Planner as usual.

I suspect that QGC isn’t aware of the ChibiOS builds (yet) so it will always load the NuttX based builds…

Hello rmackay9, I have correctly installed the firmware version to 3.6.0-rc6 in an airbotf4 (cc3d Revo F4 stm32f405) with this method:

The characteristic sound of the firmware startup, but when I restart the firmware does not start, Gives continuous beeps

I hope it will help you for the future.

Regards and thank you


I wonder if perhaps the wrong firmware was loaded to the board. As far as I know, and “airbotf4” is not the same thing as a “revo”. I think the “airbotf4” firmware can be found in this directory and the “revo” firmware can be found here.

Can you provide a link to the board you own?

1 Like

Hello again

I pass the photo of the controller board

It’s in a career drone, and the firmaware it loads is airbotf4 in betaflight

was bought in banggood



I’m not sure. It looks similar but it’s not exactly the same in appearance as an omnibus f4.

You can try asking for help in the AP/ChibiOS gitter channel although it’s not really meant for support.

1 Like

hola ramon,

afaik that’s a basic flip32 f4 without baro or mag. imho it will require at least some adjustments to hwdef to boot and run without issues. besides that you’ll likely need to add external baro and mag hardware to make full use of ardupilot features,

what exact ardupilot firmware type have you tried running on that board?
airbotf4, revo-mini or omnibusf4pro?

cheers, basti

1 Like

Hello again:
It is airbotf4, which charge betaflight

It does everything right, I even connect with the mission planner.

but when restarting, as if it will be lost.

Regards and thank you all

So it starts once but not twice? That actually doesn’t make much sense to me anyway.

Maybe the RC input throttle channel is raised it is going into the ESC calibration?

1 Like

Hello rmackay9

I’ll try it, thank you very much for the help and if I do some avence

I communicate it to you.


Hello again
I have updated the firmware plate again

This is the message that the MP gives in the message console:

Initialising APM
Check BRD_TYPE: Baro: unable to initialise driver
airbotf4 003E0027 32355110 30333937
ChibiOS: e7b6334c
ArduCopter V3.6.0-rc6 (c04a2e3f)

Then when I unplug it and restart. It’s like staying in DFU mode.
My station is connected by PPM, I have tried it on

because pwm are high if you do not turn it on, so on it goes to its right place.
It’s a shame it does not work.

It is for you to help

It is if in the future it can work with this plate

Regards and thanks for your help

@nomar I have an airbotf4 board and it works with external compass HMC5843 and baro MS5611 on I2C port (TX1/SDA, TX3/SCL), this is written in the hwdef.dat:

If you have different external baro and compass it can be changed and rebuilt. I think it is possible to use without compass but not without baro.

1 Like

I can confirm an issue as well as of a few days ago. Using Pixhawk classic flight controller. I ended up having to install a older version of the FM then using firmware from the latest directory.