I am having issues installing the 2.0.20 deb on Ubuntu 14.04. The original topic for this issue as well as some discussion on attempted fixes:
I have moved the discussion here by request of ArduPilot member billbonney
I am now working on a fresh installation of 14.04 and have added the QT 5.5.1 PPA as suggested by billbonney.
If I try to install the .deb I get the following output:
sudo dpkg -i apm_planner_2.0.20_ubuntu_trusty64.deb Selecting previously unselected package apmplanner2. (Reading database ... 420984 files and directories currently installed.) Preparing to unpack apm_planner_2.0.20_ubuntu_trusty64.deb ... Unpacking apmplanner2 (2.0.20) ... dpkg: dependency problems prevent configuration of apmplanner2: apmplanner2 depends on libflite1 (>= 1.4-release-9~); however: Version of libflite1:amd64 on system is 1.4-release-8ubuntu0.1. apmplanner2 depends on libqt5core5a (>= 5.4.0); however: Version of libqt5core5a:amd64 on system is 5.2.1+dfsg-1ubuntu14.3. apmplanner2 depends on libqt5gui5 (>= 5.3.0) | libqt5gui5-gles (>= 5.3.0); however: Version of libqt5gui5:amd64 on system is 5.2.1+dfsg-1ubuntu14.3. Package libqt5gui5-gles is not installed. apmplanner2 depends on libstdc++6 (>= 5.2); however: Version of libstdc++6:amd64 on system is 4.8.4-2ubuntu1~14.04.3. dpkg: error processing package apmplanner2 (--install): dependency problems - leaving unconfigured`
Using apt-get -f install does not fix the dependency issues.
If I use gdebi to check dependencies it tells me:
This package is uninstallable
Dependency is not satisfiable: libflite1 (>= 1.4-release-9~)
After not making any progress on trying to install the .deb, I’ve tried following the instructions on the github page to build from source.
When I try to run qmake qgroundcontrol.pro I get the following:
Project MESSAGE: Qt version 5.2.1 Project MESSAGE: Linux build x64_86 Project MESSAGE: Ubuntu Build Project MESSAGE: Release flavor Project MESSAGE: BASEDIR /home/swarmview/apm2-workspace/apm_planner DESTDIR /home/swarmview/apm2-workspace/apm_planner/release TARGET apmplanner2 Project MESSAGE: Skipping support for QUpgrade Project MESSAGE: Using mavlink + ardupilotmega Project MESSAGE: Skipping support for OpenSceneGraph Project MESSAGE: Skipping support for Google Earth Project MESSAGE: Skipping support for Protocol Buffers Project MESSAGE: Skipping support for libfreenect Project MESSAGE: Adding ALGLIB /home/swarmview/apm2-workspace/apm_planner/libs/alglib Project MESSAGE: Skipping support for XBee Project MESSAGE: Skipping support for Magellan 3DxWare (manual override from command line) Project MESSAGE: Skipping support for Opal-RT Project MESSAGE: Skipping support for Google Earth Project MESSAGE: Skipping support for Camera View Project ERROR: Unknown module(s) in QT: quickwidgets
I am unable to run make after the qmake command. I see that the output message states that the Qt Version is 5.2, and in the github instructions it says it needs to be upgraded at least 5.4.2. I’m guessing this might have something to do with the issue?
When I ran the apt-get commands to install qt components I had the 5.5.1 PPA added to my repositories (and I ran apt-get update), is there any additional configuration needed to make sure I am using the correct Qt version?
Sorry if these are trivial problems, but am a novice to linux and i am not sure how to proceed. I need to use Ubuntu 14.04 to run ROS Indigo.