Problems connecting with ArduRover v2.45 & MP 1.2.94

My problem is connecting with ArduRover v2.45 & MP 1.2.94 loaded into a ebay purchased ArduPilot Mega APM 2.6 + Ublox 6M GPS w/ compass. I had it connected once and everything seemed to work. Then Mission Planner froze so I restarted my computer and my APM. Now when I hit connect MAvlink gets to Got param RCMAP_YAW and freezes. I went through the wizard and reloaded ArduRover v2.45 and ended up in the same place when I tried to connect. I even tried loading ArduPlane and ArduCopter and they both can’t get past the connection.

With Arduplane it gets to Got param BATT_CURR_PIN and freezes.

I went back to ArduRover v2.45 uploaded it. The firmware was Verified and when I hit connect it makes it a little over half way and freezes at Got param RCMAP_YAW

I disconnected the GPS and it stopped on Got param RC11_FUNCTION

I then disconnected the reciever from the APM and it only makes it to Got param RC11_FUNCTION

I tried on another computer and same problem.
Any help would be great,

P.S.I also tried to put this in ArduRover v2.45 support but it wont let me post there.

Yes, we are tying to separate clone support from the support of official boards. We find too many clone boards have hardware issues that end up taking a lot of support time to resolve. Sorry, it is just not good use of our time.

Import clones are nothing but problems. :imp: The official board is the way to go. :smiley: I got mine in 3 days and was outside watching it fallow way points in a couple of hours. I don’t know what I was thinking.
Buyer Beware