Problems after flashing v3.6.1

I flashed my S500 quad running on Pixhawk 2.4.8 with Copter V3.6.1 few days ago and flight test today. Got log analysis with some warning. See following links to the param file.

For a start, my setting in the param were changed. All the param become the default setting after flashing. This is not the case in earlier version.

For the log analysis :–

  1. The value of LOG_BITMASK is 655358, which is Full + IMU. But log analysis says “No IMU log data”. Why ?
  2. How do I solve the Motor balance problem ? Do I re-calibrate the ESCs ?
    I don’t get this warning in the previous FW version.
  3. What is NaNs ? What does the warning “Found NaN in CTUN DSAlt” mean ? Where can I find info on it ?
  4. “THR_MIN” not found. What can I do to get rid of this message ?
  5. My current sensor has no problem. But "current " value is not shown in OSD. Voltage display with no problem. Not sure why.
    Finally, there is a param to disable the safety switch for Pixhawk in earlier version, but not now. What can I do now ?
    Thank you for any help.

Hi Frankie,

Issues 1, 3 and 4 are because the MP’s “Auto Analysis” hasn’t been updated to reflect changes in the dataflash log file format. I’ve created an issue on the to-do list to resolve this.

For (2) the motor imbalance. It is motor 4 that is the problem which is the back right motor on a QuadX. An ESC calibration might resolve it or it could be the COG is a bit off or perhaps one of the motors isn’t pointing quite straight up. The difference is about 200pwm… it’s not terrible but it’s not good either…

Re the current sensor, does the current appear correctly when connecting with the Mission Planner (or other GCS)?

BRD_SAFETYENABLE can be set to 0 to disable the safety switch.

Re lost parameters, this is not normal although we have seen a few cases of this but we haven’t been able to reproduce the issue in order to get to the bottom of the cause. I guess you don’t remember anything special during the upgrade? Any chance that you have a log file from some time before the upgrade? that might allow us to reproduce the issue.


Thanks for your reply. You reminded me of a possible cause of motor imbalance, which is COG a bit off. In my case, the 2 flight batteries (at 3S, 2200 mAh) are velcroed to the bottom of the quad frame at slighly different position every time. That is why I don’t see the motor imbalance error message everytime.

For the current sensor, there is just no display (zero) in all of my set up, a quad and 2 heli, running on either APM2.6 or Pixhawk. I remember both the voltage and current sensors were working normally 2-3 years ago in all set up.

Found the param for disabling the switch. Last few version, this param did not begin with BRD. What does BRD stand for ?

For the lost parameters, I attach the param file before flashing to Copter 3.6.1 for finding the cause.

I admire you guys being developers having coding knowledge. This enables you to understand and achieve more in this hobby at this era.



2018-11-22 17-00-16.log.param (13.5 KB)

BRD = Board, i think all board related parameters are in this group.


Thanks Corrado.

By the way, I accidentally check the “Fav” column on LOG_BITMASK in Full Parameter List so this param moved to the top of list.

How can I move this param down , according to alphabetical order ? I tried unchecked “Fav”, and still not allowed to move.

Appreciate your help.