Problem with pitch angle

We followed the wiki instructions to align our helicopter’s blade angle. However, during our test flight, the helicopter flew backward. Despite trying to pitch the nose down, it didn’t respond very well. When we lowered the throttle, it was easier to pitch the nose down, but then we lost altitude. Clearly, we have issues with the cyclic settings and most likely with the trim setting. What is the best approach to adjusting the cyclic pitch?

Here is my log and params
10 mayıs.param (19.6 KB)

Hi @Taha_Atas
looking through your log I would suggest to do the following:
1)Make sure your accelerometers are correctly calibrated. Eventually re-calibrate your accelerometers using bubble level tool;
2) Level your swashplate using the proper tool (just in case you did not do previously- set H_SV_MAN to 1 before performing this task);
3) Go through the recommended tuning procedure - all parameters are at default right now, so you can’t expect it to fly precisely.


this does not look good, collective maxed out and huge rpm variations.

Hi @Ferrosan,

Thank you for your reply. I believe that the collective being maxed out relates to our takeoff issue. We wait for the RPM to reach a certain value according to the runup parameter, but it does not go over 700 RPM even though we waited for 3 minutes. The RPM variations occur during the flight itself. I will share the flight video at the end.

I have a few other questions. We checked our blade angles when the collective and pitch were maxed out. One blade was at 16 degrees, while the other was around 6 degrees. We set our throttle curve maximum to around 80%, and the helicopter took off at about 70% throttle. We are using an OS55 Max engine, and the helicopter has 600mm blades.

We are building helicopter as a team in university so we are open to any kind of help.

Here is our flight

@Taha_Atas that is scary! please try and do little steps at a time, especially if you are new to the system.

Do you mean you set throttle curve in your remote control? Remote control must not have any pre-programmed mixing in it (like swashplate mixings or throttle/collective curves).
Throttle curve parameters in your setup are at default values.
Also, your collective is reversed:

The last time I saw something like this was when I put servos that did not have enough torque to control the swashplate. Are you sure that your servos have enough torque to control a flybarless rotorhead. Do not buy cheap servos for the swashplate.

1 Like

I meant we left default throttle curve. We did not change anything about throttle curve on our remote. I have no idea why throttle is reversed. We did not reversed the throttle. What do you think about the angle 16 when collective and pitch is maxed?

We use futaba bls275. I do not think these would not do the job. I still think it is about parameters we changed during aligment of cyclic servos.

I just checked the throttle on MissionPlanner and on my remote. It is not reversed for sure. I have no idea why it seems that way.

that is a bit tight for a 600 class, it’s a servo meant for tail rotor actuation not swashplate (high speed less torque). For a machine of that size aim at getting at least a 10kg/cm torque and 0.1s/60deg speed

1 Like

I am sorry I did edit the the servo name, we use 276 for tail and 275 for swashplate

it is reversed in your parameters:
put RC3_REVERSED back to 0

If the collective moves in the wrong direction when increasing collective on the RC use H_SW_COL_DIR parameter instead.

1 Like

oh ok, that’s goos then.

I would suggest to post more details about your setup: pictures and electronic components used.
You have severe voltage drop on the servo bus:

I think before going into details of tuning attittude and throttle curve this should be resolved.

1 Like

We tried a few things.

Now we see that even though we level our swashplate and measure the angles everywhere, when the pitch is maxed, one of the blades reaches around 7 degrees (as we adjusted), but the same blade gets a different angle when turned 180 degrees. We wonder if that effect anything or what could it be about?

And we still have no idea how to minimize our cyclic angles when both pitch and collective is maxed. We still get around 17 degrees and that, as we know, is too much.

is this a custom built helicopter or a kit you bought ?

you mentioned this is a team project for university, which suggest it’s not a kit.
which means it could be hardware design problem.

It is not fully built by ourselves. It is a prototype so we bought most of the component like pixhawk, swashplate and transmission system. But we located the servos. But I don’t think it is hardware problem since we are using pixhawk cube orange. In our opinion it could be about where the servos are located or parameters.

does the swashplate keep level when the collective moves up all the way and down all the way?
while the right stick is not touched.

since you mentioned this is an university project, is there a rc heli pilot among your team members?
if not, this is not going to be an easy project.

1 Like

@Taha_Atas is that an LM2596 like for powering the servo rail?
I’d suggest to get rid of it and install this one instead:

Don’t be shy when feeding servos, especially BLS servos.

Yes we checked first using magnet method and then we double checked it with pitch gauge. Swashplate is level.

We have someone expreinced with rc helis to help us as pilot but since we won’t fly acrobatic, is pilot really an issue?

I’m not suggesting you need to do acrobatics, but at least one of your team members should know how to hover an rc heli with some confidence. I suggest everyone in your team play with the RC heli simulator in their free time. I recommend “Hover Here”, it’s free and very well made.

looking at your photos, I see those swashplate ball link arms have extensions.
which means the servo horns has to move more, and be longer.
otherwise the servo will reach it’s limit and can move no more.