Servers by jDrones

Problem with latest APsync and RPi 3


(armadillo) #1

Hello, quick question. I have just flashed an SD with apsync-rpi-latest.img, put it in a RPi 3 B+, powered it up and am not seeing an access point.

Is this because I have not yet connected to the Autopilot or should I be seeing the access point irrespective?


(armadillo) #2

I have done some more testing and the plot thickens a lot.

I tried the apsync image and raspbian on a brand new RPi3 B+ and an older RPi 2 B. I tried two different SD cards (both taken out of perfectly working RPis) and flashed using different tools (dd in linux and Win32DiskImager in windows 10).

It seems that the apsync image flatly refuses to boot on the RPi 3. When connected to a display, it shows the rainbow screen and the lightning bolt icon indicating power issues. However, power seems highly unlikely to be the problem since I am powering it via a 2.1 Amp wall adaptor that works fine with other RPis.

The same apsync flashed SD card, boots fine on the older RPi 2 so the card is not the problem.

Also, I tried a freshly flashed Raspbian on the RPi3 and it boots fine so power is not a problem either and the RPi 3 board is fine (I thought perhaps I had bought a defective board).

So, individually it looks as if card is OK, power is OK, board is OK but the combination of those (RPi 3, latest apsync) refuses to boot. I also tried the adding “boot_delay=1” to the config.txt file trick but no joy.

So, any ideas what I might be missing? The latest apsync for the pi was uploaded on Oct 5 2017 so it seems extremely weird that nobody would have run into problems before.


(peterbarker) #3

Sorry, I haven’t updated the image to work on the Pi3B+.

People have run into this. They’ve taken the existing image and used
upgraded it. Once that’s done it works. I think someone else ran through
the instructions and made their own APSync that way :slight_smile:


(armadillo) #4

OK, thanks. One clarification, what do you mean by upgraded it? Do I plug it into a RPi 2 and run sudo apt update and sudo apt upgrade then plug it into the RPi3?


(armadillo) #5

As a reply to my previous post, I made the RPi 3 work by booting the apsync SD card with a RPi 2, running sudo apt update and sudo apt upgrade and then putting the card in the RPi 3.

However, the documentation here is screaming RPi3 everywhere so it is a major facepalm to have the official image for the RPi in the firmware not supporting RPi3. Could someone please upload a fresh image?


(Corrado Steri) #6

I had the same problem and tried same solution (sudo apt update and sudo apt upgrade) it downloaded and upgraded everything with success but the raspberry B+ still doesn’t boot. Any ideas?