Problem With ArduCopter and SITL

I was able to run the test example on windows and it worked perfectly. However, whenever i try to run the example i now get this error
$ sim_vehicle.py --map --console
SIM_VEHICLE: Start
SIM_VEHICLE: Killing tasks
SIM_VEHICLE: Starting up at -35.363261,149.165230,584,353 (CMAC)
SIM_VEHICLE: WAF build
SIM_VEHICLE: Configure waf
SIM_VEHICLE: “/home/samuel/ardupilot/modules/waf/waf-light” “configure” "–board " "sitl"
Setting top to : /home/samuel/ardupilot
Setting out to : /home/samuel/ardupilot/build
Autoconfiguration : enabled
Setting board to : sitl
Checking for ‘g++’ (C++ compiler) : /usr/bin/g++
Checking for ‘gcc’ (C compiler) : /usr/bin/gcc
Checking for need to link with librt : not necessary
Checking for HAVE_CMATH_ISFINITE : yes
Checking for HAVE_CMATH_ISINF : yes
Checking for HAVE_CMATH_ISNAN : yes
Checking for NEED_CMATH_ISFINITE_STD_NAMESPACE : yes
Checking for NEED_CMATH_ISINF_STD_NAMESPACE : yes
Checking for NEED_CMATH_ISNAN_STD_NAMESPACE : yes
Checking for header endian.h : yes
Checking for header byteswap.h : yes
Checking for program ‘python’ : /usr/bin/python
Checking for python version >= 2.7.0 : 2.7.14
Checking for program ‘python’ : /usr/bin/python
Checking for python version >= 2.7.0 : 2.7.14
Source is git repository : yes
Update submodules : yes
Checking for program ‘git’ : /usr/bin/git
Checking for program ‘size’ : /usr/bin/size
Benchmarks : disabled
Unit tests : enabled
Checking for program ‘rsync’ : /usr/bin/rsync
’configure’ finished successfully (8.308s)
SIM_VEHICLE: Building
SIM_VEHICLE: “/home/samuel/ardupilot/modules/waf/waf-light” “build” “–target” " bin/arducopter"
Waf: Entering directory /home/samuel/ardupilot/build/sitl' Waf: Leaving directory/home/samuel/ardupilot/build/sitl’

BUILD SUMMARY
Build directory: /home/samuel/ardupilot/build/sitl
Target Text Data BSS Total

bin/arducopter 1875557 54228 416 1930201

Build commands will be stored in build/sitl/compile_commands.json
’build’ finished successfully (21.544s)
SIM_VEHICLE: Using defaults from (/home/samuel/ardupilot/Tools/autotest/default_params/copter.parm)
SIM_VEHICLE: Run ArduCopter
SIM_VEHICLE: “/home/samuel/ardupilot/Tools/autotest/run_in_terminal_window.sh” “ArduCopter” “/home/samuel/ardupilot/build/sitl/bin/arducopter” “-S” “-I0” “–home” “-35.363261,149.165230,584,353” “–model” “+” “–speedup” “1” “–defaults” "/home/samuel/ardupilot/Tools/autotest/default_params/copter.parm"
SIM_VEHICLE: Run MavProxy
SIM_VEHICLE: “/usr/bin/cygstart” “-w” “/cygdrive/c/Program Files (x86)/MAVProxy/mavproxy.exe” “–master” “tcp:127.0.0.1:5760” “–sitl” “127.0.0.1:5501” “–out” “127.0.0.1:14550” “–out” “127.0.0.1:14551” “–map” "–console"
RiTW: Starting ArduCopter : /home/samuel/ardupilot/build/sitl/bin/arducopter -S -I0 --home -35.363261,149.165230,584,353 --model + --speedup 1 --defaults /home/samuel/ardupilot/Tools/autotest/default_params/copter.parm
which: no osascript in (/usr/local/bin:/usr/bin:/cygdrive/c/WINDOWS/system32:/cygdrive/c/WINDOWS:/cygdrive/c/WINDOWS/System32/Wbem:/cygdrive/c/WINDOWS/System32/WindowsPowerShell/v1.0:/cygdrive/c/WINDOWS/system32/config/systemprofile/.dnx/bin:/cygdrive/c/Program Files/Microsoft DNX/Dnvm:/cygdrive/c/Program Files (x86)/Windows Kits/8.1/Windows Performance Toolkit:/cygdrive/c/Program Files/Microsoft SQL Server/130/Tools/Binn:/cygdrive/c/Program Files/Git/cmd:/cygdrive/c/Python27:/cygdrive/c/Program Files/MATLAB/R2017a/bin:/cygdrive/c/Program Files (x86)/MAVProxy:/cygdrive/c/Program Files (x86)/MAVProxy:/cygdrive/c/Program Files (x86)/MAVProxy:/cygdrive/c/Users/samuel/AppData/Local/Microsoft/WindowsApps:/cygdrive/c/Users/samuel/AppData/Local/atom/bin:%USERPROFILE%/AppData/Local/Microsoft/WindowsApps:/home/samuel/ardupilot/Tools/autotest)
which: no xterm in (/usr/local/bin:/usr/bin:/cygdrive/c/WINDOWS/system32:/cygdrive/c/WINDOWS:/cygdrive/c/WINDOWS/System32/Wbem:/cygdrive/c/WINDOWS/System32/WindowsPowerShell/v1.0:/cygdrive/c/WINDOWS/system32/config/systemprofile/.dnx/bin:/cygdrive/c/Program Files/Microsoft DNX/Dnvm:/cygdrive/c/Program Files (x86)/Windows Kits/8.1/Windows Performance Toolkit:/cygdrive/c/Program Files/Microsoft SQL Server/130/Tools/Binn:/cygdrive/c/Program Files/Git/cmd:/cygdrive/c/Python27:/cygdrive/c/Program Files/MATLAB/R2017a/bin:/cygdrive/c/Program Files (x86)/MAVProxy:/cygdrive/c/Program Files (x86)/MAVProxy:/cygdrive/c/Program Files (x86)/MAVProxy:/cygdrive/c/Users/samuel/AppData/Local/Microsoft/WindowsApps:/cygdrive/c/Users/samuel/AppData/Local/atom/bin:%USERPROFILE%/AppData/Local/Microsoft/WindowsApps:/home/samuel/ardupilot/Tools/autotest)
which: no konsole in (/usr/local/bin:/usr/bin:/cygdrive/c/WINDOWS/system32:/cygdrive/c/WINDOWS:/cygdrive/c/WINDOWS/System32/Wbem:/cygdrive/c/WINDOWS/System32/WindowsPowerShell/v1.0:/cygdrive/c/WINDOWS/system32/config/systemprofile/.dnx/bin:/cygdrive/c/Program Files/Microsoft DNX/Dnvm:/cygdrive/c/Program Files (x86)/Windows Kits/8.1/Windows Performance Toolkit:/cygdrive/c/Program Files/Microsoft SQL Server/130/Tools/Binn:/cygdrive/c/Program Files/Git/cmd:/cygdrive/c/Python27:/cygdrive/c/Program Files/MATLAB/R2017a/bin:/cygdrive/c/Program Files (x86)/MAVProxy:/cygdrive/c/Program Files (x86)/MAVProxy:/cygdrive/c/Program Files (x86)/MAVProxy:/cygdrive/c/Users/samuel/AppData/Local/Microsoft/WindowsApps:/cygdrive/c/Users/samuel/AppData/Local/atom/bin:%USERPROFILE%/AppData/Local/Microsoft/WindowsApps:/home/samuel/ardupilot/Tools/autotest)
which: no gnome-terminal in (/usr/local/bin:/usr/bin:/cygdrive/c/WINDOWS/system32:/cygdrive/c/WINDOWS:/cygdrive/c/WINDOWS/System32/Wbem:/cygdrive/c/WINDOWS/System32/WindowsPowerShell/v1.0:/cygdrive/c/WINDOWS/system32/config/systemprofile/.dnx/bin:/cygdrive/c/Program Files/Microsoft DNX/Dnvm:/cygdrive/c/Program Files (x86)/Windows Kits/8.1/Windows Performance Toolkit:/cygdrive/c/Program Files/Microsoft SQL Server/130/Tools/Binn:/cygdrive/c/Program Files/Git/cmd:/cygdrive/c/Python27:/cygdrive/c/Program Files/MATLAB/R2017a/bin:/cygdrive/c/Program Files (x86)/MAVProxy:/cygdrive/c/Program Files (x86)/MAVProxy:/cygdrive/c/Program Files (x86)/MAVProxy:/cygdrive/c/Users/samuel/AppData/Local/Microsoft/WindowsApps:/cygdrive/c/Users/samuel/AppData/Local/atom/bin:%USERPROFILE%/AppData/Local/Microsoft/WindowsApps:/home/samuel/ardupilot/Tools/autotest)
RiTW: Window access not found, logging to /tmp/ArduCopter.log

I have tried to find the solution to this online but have had no luck

I have the same problem, did you find a solution?
I complete all steps in accordance with this manual: http://ardupilot.org/dev/docs/building-setup-windows-cygwin.html#building-setup-windows-cygwin

1 Like

Hello,

I’m also having the same problem. Did you find a solution?

Cheers,
Jon

I am having this same problem. Has anyone figured out a solution?

Please see https://github.com/ArduPilot/ardupilot/pull/12006#issuecomment-544586009

I don’t know what RiTW: Window access not found means though.

I found a solution here! My drone didnt show up in cygwin so i was getting this same message:
“RiTW: Window access not found, logging to /tmp/ArduCopter.log”

then i tried to reinstall using another version of mavproxy, specifically version 1.8.6 (you can find it here ArduPilot firmware : /Tools/MAVProxy). The error message still here, but now it works anyway.

Just came across the same problem. For me the cause was a space in the wrong place in the location.txt file. Removed the space and no more problem!