Problem Rangefinder NRA15

I’m trying to install an NRA15 radar instead of my Tf mini Plus for height measurement and at the moment it is impossible to have a measurement.

Here are my settings:
image

image

If there is some that runs with this type of radar, can you confirm my settings for me and do you have the software that allows you to check if it works correctly on a PC “MMW Radar general Management Tool”

I don’t believe we have driver support for these.

Peter

Finally, it was a Firmware problem which was not compatible with Ardupilot.
Now that I have updated the Firmware I manage to communicate with however I have a rather strange phenomen when the drone is static I have the impression that the sensor is putting on standby which displays “Bad lidar Heathl”.

I explain myself when I move the target under the radar constantly to simulate the ground, the Bad Lidar Health message disappears and when I stop moving the target, the sonarange value no longer moves and the alert message reappears.
I will also ask the supplier the question because I have the impression that the lidar is putting it on standby

Anyone have an idea on this?

I have a NRA24 and it was driving me crazy with “Bad Lidar Health” indoors. I thought there was something wrong with it. When I took it outside in a open area it worked fine. Also, keep in mind it takes it several minutes to lock in and give a reliable distance measurement.

Thank you Shotfire

I’ll do some tests outside to see then.
Thank you for the feedback

I just tested and I have exactly the same as when I am inside It is strange because apparently I can arm the device I think I will test this tomorrow because as soon as the drone moves there is no worries.
Can you send me your MP parameters and can you tell me with which Firmware you flashed the NRA24 I got this one from the supplier ( NRA15_SigPro_F303_Open_V1.0.3_Uart_Coder.zip )

hi there. I have both NRA15 and MR72. I didn’t find anything useful on the mfg website (a firmware update tool in chinese, other FW for other radars but not mine). I’m looking for the “arducopter compatible” firmwares and parameters configuration, so if someone would share here, it would be super nice :). Meanwhile i will continue to seek around

If it works correctly with your Firmware I think there is no need to touch it. In my case it was not delivered with the compatible Pixhawk Firmware, that’s why I had to make the modification. But if you want it I can always post it.

On the other hand, I am always blocked with this hyper sensitivity in Auto mode, as long as the Rngfnd_Gain will not be activated in Auto mode, I don’t see what else I can do.
It’s a shame because in the vines we have rows of 1m50 and each time the drone jumps it’s not great.
If someone has an interim solution while waiting, am I taking it?

Thank you

i’ve been contacted by nanoradar via skype, they sent me privately (?) a couple of tools and fw for ardupilot compatibility. (ps mine radars haven’t the right firmware). Also included a newer manual with params to set in MP.
As soon as i got every file, i tried to flash but i cannot go through, app tools gives generic errors or just crash (they seems very basic apps, only one has setup, other one you must click on exe file…). In the meantime skype girls went offline so here i am… :frowning:

Is it this type of error during flash ?

error

yes, mostly. Also other errors came out. It’s driving me nuts… :frowning:

the “good” news is that i can connect to the radars with that app and they show some data… at least i know my connection is good

For this problem if attached the solution :

Solution

tried it… still no success…

after some support from nanoradar (thanks) i suceed to flash arducopter fw into my two units (NRA15 and MR72). Now i’m struggling a bit with them into arducopter integration. I have a cube orange on my bench and another black in test quad. I’m still trying to figure out why i can make them work with the orange and not with the black. Same fw 4.0.2 in both. Altimeter seems to be more consistent with distance value, but i only did bench tests, i will have an idea after a flight with proper installation.
Edit: after a full reflash, also the black cube works. Anyway i can get the altimeter working with ease, but frontal avoidance (MR72), which uses the PRX library, is way more dull. I could see it showing some data once or twice, then nothing with both Cubes. Maybe it has to be put outdoor? (the other one, NRA15, seems to works quite nicely indoor)

What is the firmware version, please ?

1 Like

NRA15 : NRA15_SigPro_F303_Open_V1.0.3_Uart_Coder.hex

MR72: MR72_UAV_V1.0.0_open_20200109.bin

i’m trying the MR72 right now… it “flashes” some distance from time to time… going outside now, let me try

tried both outside taking them in hand connected to a Pixhawk then to a laptop via USB. NRA15 is nice, even if sometimes has distance “jumps” when above 10m (i think it would be better once in flight, due to lesser ground disturbances, fake reads etc), otherwise it update distances “quite consistently”.
MR72, however, is pure crap or my unit is broken. it has same beaviour as indoor. It flashes some random distance, and it updates it every like 30 seconds or more. I’m trying to understand if data is good but badly showed or it’s bad at origin.

and there we are… bad data at origin (MR72 as PRX)

…and this is NRA15 as Rangefinder (similar testing condition, unit by hand)

which looks more “consistent” to me (apart the flat areas towards end, like sensor has “frozen” for some time) anyway much better than MR72

I am curious that how you guys get the NRA15 work with Ardupilot? Did you need a radar firmware modified by Nanoradars company?

Thanks!

yes. Process is that you get the radars (with non-arducopter FW) contact them via website, they contact you by skype and a nice girl send you privately firmware files and tools to upgrade. You also need a separate serial-> usb converter if not included in your order. Then you flash, do your wires (e.g. Pixhawk connectors, connect, configure pixhawk and voilà, you get distance measurements.