Problem Installing Copter 3.6 Firmware to Pixhawk 1

Hello, I am having problems with installing the arducopter 3.6 firmware to my Pixhawk 1. This is an unedited fork of the ardupilot code. I used the WSL waf compiler to compile my code. In the terminal, it appears to compile successfuly. But, when I go to install it on my Pixhawk 1 using Mission Planner, the Pixhawk doesn’t operate correctly after the install. The first sign that my Pixhawk is not operating correctly is that it doesn’t play the musical tone right after the firmware installs. Also, it won’t connect to mission planner. My assumption is that their is some issue with the firmware because my Pixhawk 1 will work fine with the latest arducopter firmware that is found on Any assistance would be greatly appreciated.

So it works fine with the latest stable release, but it does not work with your compiled code?
I advise you to checkout the git release branch, and compile and test that one first.

Did you check that your pixhawk is Px4v2 or Px4v3 and compile the right version ?

Yes, the stable release found on the ardupilot website worked, but my compiled version did not. I’m not sure I follow you on the “git release branch”. Can you explain further?

I didn’t realize there are different versions of pixhawk 1. How can I tell what version I have? Also, when I compiled using waf, there is only one pixhawk 1 configuration. What configuration would I select besides the pixhawk 1 configuration?

It can be px4-v2 or px4-v3 based on the cpu revision. v2 has an older cpu which has a bug causing only 1MB flash available. px4-v3 has 2MB flash.

Load a released firmware and check bootup message in mission planner. Then select the appropriate build target.

This is what it says in the message terminal in Mission Planner after I installed the latest released firmware and connected the pixhawk to mission planner.
u-blox 1 HW: 00040007 SW: 7.03 (45970)
Frame: QUAD
Pixhawk 1 0040002C 35324719 36343032
ChibiOS: d2030d88
ArduCopter V3.6.8 (2f409678)

Oh yeah, with ChibiOS it was renamed to Pixhawk1… then it is a mistery… .

Do you think I should just use trial and error and compile under different the two different px4 configurations until it works?

Pixhawk1 - ChibiOS target, I’m not sure but it seems it does not makes difference between v2 and v3 boards…

px4-v2 and px4-v3 targets are building NuttX versions.
try both of them and see which one runs on your board.

I got error messages when trying to configure for the px4-v2 and px4-v3 boards… Not sure why they would list those as board options and it not be able to configure for them. Maybe I don’t have something installed correctly with my WSL ubuntu setup.

Are you sure you checked out Copter-3.6 tag, not the master ? (In master Nuttx was removed)

I used the command “git checkout Copter-3.6”. I know don’t have the master checked out, but i’m not sure if there is a difference in a branch and a tag.

Sorry Copter-3.6 is a branch

In my 3DR Pixhawk1, the following is displayed as MP.
It is fmuv3.
I have a 3.7dev development version
./waf configure --board fmuv3
Built and successfully uploaded.
Frame: QUAD
fmuv3 00560028 35345107 34343430
ChibiOS: d2030d88
ArduCopter V3.6.8 (2f409678)

I tried compiling the firmware configured as both fmuv2 and fmuv3 and still don’t here the musical tone and the board is unable to connect to mission planner. Not sure what I am doing wrong. I think I am messing something up during compiling of the firmware.

I can check if the firmware I built with fmuv3 can be written to my fc. Please put the link of the firmware.

Sorry for the late response. Here is my compiled fmuv3 firmware: arducopter.apj (840.5 KB)

Eosbandi, is it possible for me to not have set up the compiler correctly? I figured that if the compiler was not set up correctly, I would just get an error while compiling. Am I thinking about this correctly?

It does not work when uploaded.