Servers by jDrones

Problem Calibration BLHELI-S And Pixhawk 2.4.8

Hello !!

I have a problem with my Drone (Quad X) when i want to make my ESC calibration.

My hardware :
FC : Pixhawk PX4 2.4.8
ESC : Blheli-S 30A
Moteurs 220S 2550KV
Radio commande : FS-I6X
Recepteur : FS-IA6B

When i make calibration with mission planner, the drone restart in calibration mode, he make calibration without problem (test with “normal type” and “OneShot type”).
When i restart in normal mode and when i arm motors, when i touch throttle on my transmitter (very little bit…), motors speed from 1000 to 1400, even if i stop to touch throttle (just motors 2 and 4…
And after 50% of my throttle on my transmitter, motors are allready at maximum.

So, i make calibration without mission planner, just with the normal procedure (connect battery, disconnect battery, connect battery with max throttle, wait beeps finish, put throttle at minimum and wait beeps for finish.

This is perfect and i have the good amplitude 1000 to 2000 on my throttle and motors works perfectly !

My problem is when i reboot my done after esc calibration… i return to the first state and the good state whith the “manual calibration” isn’t sae on my ESC…

Help me please, i’m newbie and i have no more ideas for resolve my problem !

Sorry for my English !!!

Thanks in advance !

Good day, before calibrate your esc…, do you perform the radio calibration? Just check also if you esc is oneshot or oneshot 125…you must set the correct one before proceed esc calibration

Hello ! Thanks for your response.

Radio calibration is OK (before ESC calibration…)
I’ve test with OneShot125 too, but it’s the same issue…

Have you other ideas ?

Have a nice day !

Are you using sbus protocol for your rc? do you have wired your esc on aux or servos?

How are you testing this? On the bench with no props? If so this is meaningless.

1 Like

I use PPM protocol. And i’ve wired my esc on servos pin. how it’s specify in this doc : https://ardupilot.org/copter/docs/connect-escs-and-motors.html

It’s not a good thing ?

Hello, Thank you for your answer !

I test on a bench with no props.
But why it is meaningless ?

why in a real situation, i will have all amplitude of my throttle on my RC ?

me i use to connect bheli esc on aux channels… sbus is more fast and stable than ppm…

Because the motor output is in a closed loop and sitting on the bench there is no feedback from the sensors so what you witness the motors doing is meaningless. Well, other than they spin and the direction they spin in. Also, PPM is an RC Protocol, I assume you mean PWM. With BLHeli_S ESC’s you can run Oneshot125 at best but this won’t really make much a difference from PWM. And using the Aux channels is only valuable if you are using Dshot which those ESC’s probably don’t support.

I’m not sure to understand.

It’s just for be sure before change because i was obliged to cut 3 AUX Pin for put my pixhawk board on my frame (so it’s possible to connect but with welding…).
And dorne crashed already 2 times, so i prefer be sure before the third !! ^^

I’ve no problem with RC connexion with my drone. PPM connexion is OK because when i am in calibration mode for my esc, esc have the good calibration, so when i put my RC Throttle to min, motors are stopped, and when i put my RC throttle to max, motors are in maximum (and motors are not in maximum at 50 percent of my RC Throttle even if i am on a bench with no props).

The problem is just when i disconnect my battery, the next time i connect it, the esc calibration is not preserved…

So maybe my English is too bad, or maybe i don’t understand how it’s work. In two case, i’m sorry for this additionals questions.

Thanks you for all !

Post a parameter file, maybe something can be discovered there.

bkp_params_ardupilot.param (17.5 KB)

I don’t see anything in the parameter file to suggest a problem with ESC calibration. Put some pros on and fly it.

I tested with props in my garden, but drone goes forward and crash… I tested to put battery a little bit behind drone (in the case where drone weight is’nt distributed properly) but the result is the same, drone goes forward and crash.
And another thing, he “shake” a lot before take off. (i don’t know if “shake” is the good word in english…)

So i think esc calibration is always the problem, and the “manual calibration” who don’t save is the normal state for fly, but not possible for the moment due to my problem… :frowning:

Does it run properly in Mission planners Motor Test? Motor order correct and props turning in the right direction? Pay attention to the note describing the order the motors are run in when selecting the A-D buttons. It’s not clear to me that this has anything to do with ESC calibration.

I’m sure for props turning in the right direction.
For motor orders, i’ve use this doc : https://ardupilot.org/copter/docs/connect-escs-and-motors.html

When i test motors one by one, i have this order :

front right : A
behind right : B
behind left : C
front left : D

I don’t know if this order is good because in one case, http link speak with numbers and mission planner with letters (A=1, B=2… ???). I’m not sure for this point… So i trusted the ardupilot documentation in the doubt…

Good day, when you are testing the motors without props…you have check the correct rotation… cw and cww?
motor 1 and 2 must be cww… 3 and 4 must be cw.
just check also the correct wire on your fc

Good d’au. Yes, i’m sûre. Vérification ok.

Front left ans behind right in normal rotation and the 2 others in reverse rotation

And if you input throttle percentage values from 5% to 100% in steps do the motors progressively spin faster? If so it’s not an ESC calibration problem.

Yes, motors progressively spin faster. But i don’t understand why i have two different possibilities of calibration with two different results.

  1. With mission planner, click on “calibrate” Burton, unplug battery, plug battery, and ESC calibration make without mu intervention. After reboot drone in normal mode, i havn’t all amplitude on my throttle. Motors spin a little bit at the minimum throttle and they are at 100% when throttle is at 50%.

  2. Without mission planner, i unplug battery, i plug battery with throttle max on my RC, so ESC is in calibration mode, i put throttle at min after safety switch on, ESC wait value of min throttle so i put my throttle to min, ESC beep for Say “it’s ok for me”, and when i touch throttle after calibration, he World perfectly ! But when i reboot drone, he return to normal mode and he doesn’t have anymore configuration !

So i’m not sure first calibration is a good calibration, but it’s the only one i can use due to m’y problem…

Why two differents possibilities of calibration with differents methods ans differents results ?

Servers by jDrones