Servers by jDrones

Problem althold, attitude hold, heading hold

Hallo Felix,
bin leider immer noch nicht zum fliegen gekommen,da jetzt der Regler ausgestiegen war…
Falls Du die Tage schreibst, ich bin von morgen bis 13.11. im Urlaub.

Viele Grüße Holger

Hallo Holger,

entschuldige bitte die späte Antwort. Im Moment ist es gerade sehr hektisch bei mir…

Dass Du jetzt immer eine Verbindung mit MP herstellen kannst und das Problem mit Motor interlock gelöst ist, sind doch schonmal sehr gute Nachrichten! Alles andere was Du beschreibst, sind glaube ich wesentlich einfacher zu lösende Probleme.

Machen wir uns mal dran:

Das liegt auf jeden Fall an Deinen Werten für die H_RSC-Parameter. Du betreibst den Heli vermutlich mit H_RSC_MODE=2, richtig? So mache ich das jedenfalls. Der Wert auf den der Balken hochläuft wird von H_RSC_SETPOINT vorgegeben. Die Zeit, in der er hochläuft wird durch den Parameter H_RSC_RAMP_TIME gesteuert. Wenn du einen Softanlauf im Regler nutzt, kannst Du das auch auf 0 setzen. Dann ist der Balken sofort oben. Wichtig ist auch H_RSC_RUNUP_TIME. Der Wert sollte so groß sein, wie Dein Rotor tatsächlich zum hochlaufen braucht. Damit der Heli weiß, wann er bereit zum Abheben ist.

Ich würde Dir empfehlen, nochmal die Setup-Videos von Chris anzuschauen. Da beschreibt er das alles sehr ausführlich.

Dass der Anfangswert zu hoch ist, wundert mich ein bisschen. Vermutlich liegt das an Deiner RC-Kalibration. Vielleicht solltest Du das nochmal neu machen und darauf achten, dass wirklich alle Kanäle an die Anschläge bewegt werden.

Du solltest unbedingt alle Einstellungen immer in der „Full Parameter List“ vornehmen. Alles andere hat z.B. Begrenzungen, die teilweise für Helikopter falsch liegen. In der Full Parameter List sollten dann aber alle Werte auftauchen. Ist das bei Dir nicht so? Falls nein, poste doch mal einen Screenshot.

Hier ist übrigens noch eine Übersicht, über alle Parameter und deren Funktion:

http://ardupilot.org/copter/docs/parameters.html

Das Problem mit Deinem Kompass kann daran liegen, dass sich ferromagnetische Materialien in der Nähe befinden. Dann hast Du recht hohe Kalibrationswerte. ODER: Der Kompass hat eine ganz andere Einbaurichtung als die internen Kompasse. Bei manchen Herstellern stimmt der Pfeil auf dem GPS nicht unbedingt mit der internen Einbaurichtung des Kompass überein. Das müsstest Du dann für Dein Modell googeln. In MP kannst Du Dir auch live Daten plotten lassen. (Kennst Du die Funktion?) Wenn Du das mit den unterschiedlichen Kompassen machst, könntest Du überprüfen, ob sich die Werte in die gleiche Richtung verändern oder komplett spinnen. Ist letzteres der Fall, stimmt Deine Einbaurichtung nicht. Du musst den Kompass dann allerdings nicht wieder ausbauen. Das kann man auch elektronisch kompensieren.

Die Meldungen „EKF primary changed 1“ usw. kannst Du ignorieren.

Dann scheint Dein Heli noch mit irgendwas Probleme zu haben. Eigentlich ist es ja gut, dass Du den Modus nicht wechseln kannst, wenn der nicht zuverlässig funktioniert. Wenn Du das Setup sauber gemacht hast, passiert das nicht mehr. Ich bin mir nicht ganz sicher, ob das evtl schon mit Deinem Kompass zu tun haben kann. Für die Flugmodi, in denen Du GPS brauchst (POSHold, Auto usw.) funktioniert das Wechseln dann natürlich auch nur, wenn Du guten GPS-Empfang hast.

Dass die FW 4.0.0 ohne Fehlermeldungen wechselt finde ich etwas erstaunlich. Die Meldungen haben aber ihren Grund. Von daher solltest Du vor dem Flug unbedingt der Ursache auf den Grund gehen. Solange die 4.0.0 noch nicht als stable release veröffentlicht ist, würde ich Dir übrigens nicht empfeheln, sie zu verwenden.

Das weiß ich ehrlich gesagt gar nicht. Bisher hat mich das auch nicht interessiert, da ich das Arming für eine sehr nützliche Funktion halte. Nicht nur was unbeabsichtigtes Anlaufen betrifft. Das Arming verhindert ja auch, dass Du starten kannst, wenn irgendwas mit Deinem Board nicht stimmt (Prearm-Checks). Von daher würde ich das einfach drin lassen. Den einen Schalter umlegen ist ja jetzt nicht so anstrengend…

Tut mir leid, dass Dein Regler nicht mehr funktioniert. Naja aber es ist sowieso sinnvoll, erstmal alles korrekt eingestellt zu haben und dann zu fliegen. Das kann mitunter sehr viel Zeit sparen…

Ich wünsche Dir einen schönen Urlaub! Schreib mir wieder, wenn es etwas Neues gibt.

Viele Grüße

Felix

Hallo felix, kein Stress, alles nur Hobby…
einiges ging ja mittlerweile, so z.B. der zweite Compass.

in H_RSC_Mode habe ich die 1, das funktioniert jetzt auch gut
habe ich auch gelöst. Im servo-Menue sind alle Servoausgänge bei min. auf 1100. Mein Regler hat als Start aber nur ca. 950, hatte ich so eingelernt. deswegen ging das nicht. Wenn man den unteren Wert vom Servo 8 einfach runternimmt auf 950, geht das. den oberen Wert kann man so ja auch vergrößern, falls nötig.


hier ein Beislpiel für Nicht-Anzeige: die classes 10 - 13 fehlen einfach.

weiteres Beispiel:


ich weiß zwar nicht ob ich die brauche, aber ist ein typisches Beispile dafür, was ich meine.

oder hier nochmal

wie gesagt, bei meinen beiden Bekannten wird alles korrekt angezeigt, Bei Dir vermutlich auch?

Ansonsten: neuer Regler da, geht nach dem urlaub los.

Hallo Holger,

ich hoffe, Du hattest einen schönen Urlaub? Jetzt ist der schon wieder vorbei und ich bin noch immer nicht dazu gekommen, Dir zu antworten…

Schön, dass Du Dein Reglerproblem gelöst hast. Dann scheint ja jetzt alles ziemlich gut auszusehen.

Der Frage mit den fehlenden Parameter-Beschreibungen in MP bin ich jetzt auch mal nachgegangen. Bei mir wird tatsächlich mehr angezeigt als bei Dir. Aber nicht in allen Punkten. Manchmal ist das bei mir auch nicht vollständig. Hier z.B. fehlt auch die Beschreibung für die Einstellung „3“:


Ich glaube, das ist abhängig von der Firmware, die man verwendet und v. a. auch vom Board. Du verwendest ja einen anderen Controller als ich. Gut möglich, dass die Unterschiede daher kommen. Wie Du selber festgestellt hast, ist davon aber die Funktion nicht beeinträchtigt. Von daher würde ich Dir einfach empfehlen, die Liste hier zu nutzen. Da sollten alle Beschreibungen drinstehen:
http://ardupilot.org/copter/docs/parameters.html

Melde Dich, wenn’s was Neues gibt…

Viele Grüße

Felix

Hallo Felix,
danke - gestern aus dem urlaub zurück. möglicherweise hast Du recht. Aber z.b. beim Frame_class wäre es unlogisch, nicht alle 13 anzuzeigen?

Werde je nach Wetter die näschsten Tage fliegen und weiter berichten.

Gruß holger

Hallo Holger,

so wie ich das verstehe, liegen die Infos ja auf dem Board. Von daher könnte ich mir vorstellen, dass da jemand Speicher sparen wollte und die weniger wichtigen Sachen weggelassen hat. Ich weiß nicht, was Dein Board hardwaremäßig hergibt. Naja, vielleicht liege ich auch falsch, aber da es die Funktion des Controllers nicht beeinträchtigt, ist es ja ziemlich egal. Ich nutze jedenfalls immer die Seite, die ich Dir gestern geschickt habe, wenn ich die Parameter nachsehen will. Hat außerdem den Vorteil, dass ich es auch sehen kann, wenn MP gar nicht verbunden ist.

Viele Grüße und viel Erfolg bei Deinen Flügen

Felix

Hallo Felix,
ich werde meinen FC mal bei meinen beiden Bekannten anschließen und sehen, was dann angezeigt wird.
irgendwie denke ich , dass da noch wa anderes sein muss. Werde berichten, natürlich auch über die ersten (weiteren) Flüge.

Viele Grüße Holger

Hallo Felix,
kurze Ergänzung: es sieht im Moment alles sehr gut aus. Es läuft auch alles (offenbar richtig) mit der FW 3.6.11. Keine Fehlermeldungen, alle modes zu schalten.
Aber zwei Sachen:
Ich schaffe es nicht (mehr), die Kompasse zu kalibrieren, selbst wenn der grüne Balken bis rechts geht, kommt der “abfällige” Ton. Gibt es da Tricks?

Und: heute das teil im Garten das erste mal probelaufen gelassen. Und da: schon beim Hochlaufen bzw. kurz danach laufen die beiden Taumelscheiben nach links und rechts (oder umgekehrt), als wenn man Seite (yaw) steuern würde. das geht bis zum Anschlag. man kann sie zwar mit dem Knüppel wieder in die waagerechte steuern, aber wenn man hier auch nur einen kurzen Impuls zu viel macht, laufen sie weiter in die entgegengesetzte Richtung bis zum anschlag. Wenn man dann auf “disarmed” geht oder den Motor ausschaltet, springen sie sofort wieder in die waagerechte. Wenn man dann den Motor wieder anschaltet (und offenbar der letzte steuerimpuls noch drin ist) laufen sie beim hochlaufen wieder in die vorige Stellung zum Anschlag.

Dieses Verhalten ist bei der 3.6.11 und bei der 4.0.0 gleich. Ich habe glaube ich wirklich alles probiert. Auch wegschalten der beiden kompasse ändert nichts.

Dass passiert auch in allen Modi, wobei im “stabilize” wo der Heli ja waagerecht am Boden steht, es keinen Grund für einen Steuerimpuls gäbe.
Ich bin ratlos. Ideen?

Viele Grüße Holger

Hallo Holger,

das sind doch schonmal tolle Neuigkeiten. Freut mich, dass es jetzt soweit funktioniert.

Ein paar Tipps zum Kompass kalibrieren:

  • möglichst keine ferromagnetischen Bauteile in der Nähe
  • die Kalibration draußen durchführen (nicht im Haus) Da ist das Magnetfeld zu stark verändert
  • darauf achten, dass die Kompasse alle die richtige Einbaurichtung haben

Ich habe das Gefühl, dass es bei Dir der dritte Punkt ist. Schau mal in der Live-Anzeige von MP, ob die Graphen der verschiedenen Kompasse wenn Du das Modell bewegst alle in die gleiche Richtung laufen. Wenn nicht, ist es klar, dass es nicht funktionieren kann…

Um die Sache zu vereinfachen, kannst Du auch mal die internen Kompasse deaktivieren und nur den von GPS nehmen. Der ist meist der Beste, weil er weit weg von allen Störungen ist.

Zu Deinem Taumelscheibenproblem: Das klingt für mich so, als ob der „Ghost“ (der virtuelle Heli, der die Soll-Fluglage darstellt) beginnt, vom realen Heli abzuweichen. Demzufolge versuchen die Taumelscheiben den echten Heli mit aller Kraft wieder auf den Ghost zu bringen. Wenn man den Heli disarmed wird der Ghost hart auf den realen Heli zurückgesetzt. Daher das Springen der Taumelscheiben.

Meine erste Vermutung wäre, dass Du Probleme mit Vibrationen hast und oder Dein Kompass-Problem dazu führt. Wenn der Heli annimmt, er hätte sich weggedreht, ist es ja ganz normal, dass er versucht, das wieder zu kompensieren. Von daher würde ich mich als erstes darum kümmern, dass der Kompass einwandfrei arbeitet. Es ist ganz wichtig, erstmal ein sauberes Setup zu haben. Dann funktioniert der Rest meist von ganz alleine.

Meine andere Vermutung wäre, dass Deine Sender-Nullstellung nicht richtig kalibriert ist oder die Yaw-Tuningwerte zu hoch sind und der Heli deswegen einfach viel zu sensibel reagiert. Aber ich denke eher, dass es die Kompass-Sache ist.

Viele Grüße

Felix

Hallo Felix,
wiederum danke, ich hätte auch noch ergänzungen:

An Vibrationen liegt es nicht. der Effekt ist auch ohne Rotorblätter da. Er ist sogar dann da, wenn ich den Motor abstöpsele, er also nicht laufen kann. Wenn ich ihn dann einschalte (über CH8) kommt der gleiche effekt.
und auch, wenn ich beide kompasse im menue weggeschaltet habe.

Allerdings war mein yaw P noch sehr schwach eingestellt (grundeinstellung). habe ich erhöht, ist da scheinbar deutlich besser, aber noch nicht ganz weg.
Man kennt das ja vom single-heli, wenn er mit heading hold eine weile laufend am Boden steht, fängt er manchmal auch an, sich langsam wegzudrehen.

Hier im FC / MP scheint ja immer heading hold zu sein. kann man das irgendwie weg- / umschalten / regeln / reduzieren? einen single-Heli (und auch den Tandem) kann man ja ganz gut auch mal ohne heading hold fliegen.
Bei meinem großen Tandem habe ich Pitch / yaw über einen Mischer im Sender so programmiert, dass ich bei Pitch-minimum immer “normal” - also nicht heading hold habe. erst bei leicht über minimum schaltet er in “HH” um. Wäre das im FC auch hinzukriegen?

hat den Vorteil, dass am Boden nichts passieren kann und bei einer unsauberen, drehenden Landung die Taumelscheiben nicht verdrehen bzw. gleich wieder gerade sind.

mal in die Zukunft mit Sonar gedacht, könnte man, wenn es grundsätzlich geht, das ja auch möglicherweise über das Sonar programmieren?

den internen kompass konnte ich mittlerweile kalibrieren, den im GPS noch nicht, habe es aber bislang nur drinnen versucht. Wie muss ich ihn denn sinnvollerweise bewegen?
und was bedeuten “urban declination automatically” und “automatically learn offsets” - beide ja im compass-menue oben anzuclicken?

bei meinen Versuchen habe ich nun gemerkt (was offenbar auch Ursache für viele Fehler war),
dass der FC auf jeden Fall “armed” sein muss und AUCH der Motor laufen muss. erst dann geht offenbar alles richtig.

so kann ich auch auf dem tisch bei laufendem Motor und alt-hold mit dem pitch hoch- und runterfahren.
einmal im flug aktiviert, müsste man damit sogar landen und wieder starten können.

Leider lässt das Wetter jetzt am WE keine Flüge oder Proben im Garten zu.

Viele Grüße Holger

Hallo Holger,

ach so, wenn Du bei den Tests keine Rotorblätter drauf hattest, kann das natürlich sein. Der Heli stellt eine (minimale) Abweichung zur Soll-Fluglage fest. Das versucht er zu korrigieren – was natürlich nicht funktioniert, weil er ja keine Blätter hat. Je länger die Abweichung besteht, desto mehr wächst der I-Wert an und versucht mit immer größeren Steuereingaben Deinen Heli in die Soll-Lage zurückzudrücken. Das müsstest Du auch in Deinen Logs sehen können?

Mit dem Yaw-P-Wert würde ich vorsichtig sein. Es kann natürlich sein, dass Du für Deine Tandem-Anordnung eine höhere Einstellung brauchst. Aber taste Dich da lieber vorsichtig ran. Dass ein höherer Yaw-P-Wert Dein Problem mit den weglaufenden Taumelscheiben löst, kann ich mir ehrlich gesagt kaum vorstellen. Ich hätte eher das Gegenteil erwartet. Der Grund, warum sich Dein Single-Heli im Heading hold wegdreht, sind übrigens die Vibrationen. Der Controller driftet mit seiner Lageeinschätzung einfach ein bisschen ab und führt den Heli entsprechend nach. Das wird Dir nicht passieren, wenn Du funktionierende Kompasse hast.

Das ist ja mal ein interessanter Trick, dass Du unterhalb einer gewissen Pitch-Grenze einfach heading hold ausschaltest. Hmm, ich glaube so richtig ist das in Ardupilot nicht vorgesehen. Probier mal aus, wie Du mit dem System zufrieden bist, wenn Deine Kompasse funktionieren. Denke dann sollte das auch bei der Landung (und längeren Phasen am Boden) kein Problem sein. Theoretisch könntest Du natürlich den Yaw-I-Wert über Deinen Tuningkanal herausnehmen. Aber ich glaube es ist eher nicht gut, absichtlich größere Abweichungen zum Ghost entstehen zu lassen.

Zum Kompass-Kalibrieren gibt es viele schöne Videos. Schau mal hier rein:

http://ardupilot.org/copter/docs/common-compass-calibration-in-mission-planner.html

Da stehen auch die Antworten zu Deinen anderen Fragen…

Viele Grüße

Felix

Hallo Felix,

ach so, wenn Du bei den Tests keine Rotorblätter drauf hattest, kann das natürlich sein. Der Heli stellt eine (minimale) Abweichung zur Soll-Fluglage fest. Das versucht er zu korrigieren – was natürlich nicht funktioniert, weil er ja keine Blätter hat. Je länger die Abweichung besteht, desto mehr wächst der I-Wert an und versucht mit immer größeren Steuereingaben Deinen Heli in die Soll-Lage zurückzudrücken. Das müsstest Du auch in Deinen Logs sehen können?

Der Effekt war mit und ohne Blätter. Auch sogar, als ich den Motor abgestöpselt habe. Beim Einschalten des Motors (=positiv auf Ch 8) gingen die TS auch bei null Vibrationen auf die Seite.
Nachdem ich den P-Wert erhöht habe, ist es gefühlt etwas besser geworden. Den brauche ich ohnhin relativ hoch, weil man beim Tandem yaw (Hochachse) nur mit relativ starken Ausschlägen vernünftig steuern kann. Den I-wert habe ich noch nicht so beachtet, ich dachte immer, der ist für das längere halten einer bestimmten Richtung / Ausschlag zuständig. wieviel ich I ich beim tatsächlichen fliegen brauche, werde ich sehen.
Immerhin hatte ich Probelauf im Garten. da war der Efelkt wie beschrieben. Auch etwas besser geworden nach Abschaltung des (nichtcalibrierten) Kompasses.
Beim Hochlaufen durch die Schwingungen und Vibrationen kommt das und die Taumelscheiben laufen weg. wenn ich sie dann mit knüppel in die Mitte nehme, halten sie auch schon ganz gut.

Was ich nicht verstehe: warum der Effekt auch bei Stab und mit ausgeschalteten Kompassen entsteht.
in dem Zustand besteht doch eigentlich keine Notwendigkeit, eine Richtung nachzuführen.
Im Übrigen scheint mir das heading hold auch ohne Kompass nur mit den Sensoren zu funktionieren. normale FBL haben ja auch keinen Kompass drin.

Das Ausschalten vom HH bei mir mache ich über einen Mischer im Sender. Beim normalen FBL kann man ja immer -normalerweise über einen Regler- zwischen HH und normal umschalten. Mit dem Mischer und den beiden Funktionen Pitchknüppel / HH-normal kann man das ja so hinkriegen, dass eben ab einem minimalen Pitchwert es auf HH umspringt.
Für diverse Versuche am Boden ist es auch nötig, diese neutral ohne hh durchführen zu können.

Insofern wäre es schön, wenn man das hier auch hinkiegen könnte. Meinst Du, I auf null würde das bringen? Unabhängig davon gibt es doch viele Piloten, die ohne hh fliegen (wollen), weil es ja auch geht und sie es können. Wenn der FC das nicht zulässt, wäre das ein kleiner Nachteil. Zumindest im acro sollte / müsste es gehen.
Ich glaube, der yaw-I wert ist im Tuningkanal garnicht drin.

Zumindest am Boden bei Pitch-minimum sollten die TS gerade bleiben. deshalb jauch meine individuelle Einstellung.

Was ist eigentlich mit dem D - Wert?

Beim Kompass habe ich wirklich alles versucht, alle Hinweise gelesen und befolgt, in den params nach wiki den off-Wert erhöht usw. Es ist ja auch nur der Kompass im GPS, der interne tuts ja problemlos.
Bei meinem vorigen, zurückgeschickten pix ging es ja auch.
Kann der Kompass ggf. defekt sein, auch wenn der grüne Balken durchläuft?

Leider nach wie vor kein Flugwetter…

Viele Grüße Holger

Hallo Felix,
kleine Ergänzung: Alles läuft!
war heute draußen und habe probiert. alle Funktionen, Modi usw. gehen, keine Fehlermeldungen. Die beim Hochlaufen verdrehten Taumelscheiben sind noch leicht da, aber beherrschbar.
Nun geht es an die Feineinstellungen, dehalb bist Du noch nicht entlassen!

Trim
habe es nach Anleitung mit “save trim” versucht (er driftet leicht nach vorn rechts), er nimmt die Änderungen aber nicht an.
Muss man “save trim” mit dem Schalter CH7 machen, wenn der Motor noch läuft? armed oder disarmed?

Höhe halten
Geht wunderbar in allen Modi. Allerdings fängt er -je nach Fluglage oder Steueraingabe- an, sich um die Nickachse (pitch) leicht aufzuschaukeln. Habe es zunächst mit Pitch P weniger versucht - keine Änderung. dann mit Stab-Pitch P weniger, da wurde es besser bzw. irgendwann weg.
was kann da die Ursache sein? bei Acro und Stab macht er es nicht.
Der FC bekommt ja den Abwind von den Rotorblättern ab. kann es sein, dass der den Baro stört? trotz Gehäuse? Oder gibt e noch eine andere mögliche Ursache?

Pos hold
funktioniert. Aber die schwankungen zum zurücksteuern werden immer ausladender, der kreis beträgt dann schon einige Meter. Da müsste das GPS genauer sein und / oder die Korrekturen müssten deutlich schneller (und damit auch kürzer und kleiner) sein.
kann das u.U. (auch) damit zusammenhängen, dass er noch nicht richtig getrimmt ist?

Autotune
habe ich noch nicht probiert, geht das beim Heli auch? und wenn, wie am besten?

danke und viele Grüße

Holger

Hallo Holger,

erstmal Glückwunsch zu Deinem erfolgreichen Flug! Ich bin leider bis einschließlich Donnerstag noch so beschäftigt, dass ich noch nicht ausführlich auf Deine Fragen eingehen kann. Aber so viel schonmal vorab:

Autotune funktioniert mit Helis nicht. (Zumindest hat es noch keiner erfolgreich getestet.) Ich würde aber dringend davon abraten, es auszuprobieren.

Das mit Deinen Nickschwingungen könnte einfach an einem schlechten Tuning liegen. Versuch mal, Dich an der Anleitung so gut es geht voran zu hangeln:

http://ardupilot.org/copter/docs/traditional-helicopter-tuning.html

Wenn der Heli dann im Acro auf plötzliche, scharfe Steuereingaben sauber reagiert und Deine Nick-Schwingungen noch immer vorhanden sein sollten, könntest Du mal probieren PSC_VELXY_P zu verändern. Das ist der P-Wert von Deinem Positionscontroller. Der gibt vor, wie aggressiv der Heli versuchen soll, seine Position zu halten. Zuerst würde ich mich aber ums Tuning in den manuellen Flugmodi kümmern.

Ich versuche, Dir bald ausführlicher zu antworten.

Bis dann

Felix

Hallo Felix, danke erstmal, dann schaue ich mal und warte auf Deine weiteren Ausführungen.

Viele Grüße Holger

Hallo Holger,

was ist der aktuelle Stand? Jetzt habe ich wieder etwas mehr Zeit. Hast Du den Kompass inzwischen kalibrieren können?

Viele Grüße

Felix

hallo Felix, jetzt erst gelesen.
schreibe morgen mal was auf.

Gruß Holger

Hallo Felix, nun aber.
das kompass-kalibrieren habe ich nach endlosen Versuchen aufgegeben, aber mit dem internen geht es auch gut.

War zwischenzeitlich mal los.
allerdings hat sich von meiner ersten Meldung am 26.11. nicht viel geändert.

Erstmal: alles scheint grundsätzlich zu laufen, keinerlei Fehlermeldungen.

habe mittlerweili in acro die PID’s einigermaßen hinbekommen, die Feinarbeit muss noch folgen.

In Stab driftet er nach rechts, trotz ausrichtung und leveling am Boden. geht mit trimmung wegzutrimmen.
aber “save trim” mit ch7 geht nicht, er behält die Trimmwerte nicht.
Auch wenn ich am boden ihn bewusst nach links zur Seite neige und dann leveling mache, driftet er nach rechts. erst wenn man in der para-liste den wert extrem erhöht, geht es. eigentlich müsste man ja denken, wenn man ihn in acro gerade hat und auf stab umschaltet, dass er das übernimmt. tut er aber nicht. wenn man am boden von acro auf stab umschaltet, sieht man auch, wie beide TS leicht nach rechts gehen.
werde nochmal die gesamte mechnik auf rechtwinkeligkeit untersuchen. allerding in acro damit kein problem.

Dann höhe halten.
macht er ziemlich gut. allerdings beim umschalten auf höhe halten (oder die anderen höhen-modi) fangt er an, sich leicht über nick / die gesamte höhe aufzuschwingen. das konnte ich bislang nur durch deutliche verringerung von Stab pitch P verhindern. (was da dann natürlich eine geringere Nick-haltung bedeutet).
Den gleichen Effekt hatte ich beim ersten ausprobieren überhaupt mit dem DJI NAZA M (fertige coptersteuerung).
Mein Verdacht: der FB liegt ja jetzt noch ohne Rumpf direkt im Luftstrom von wenigstens einer rotorebene. kann es sein, dass dadurch das Baro so gestört wird, dass es zu diesen "Korrektur"schwingungen kommt?
Oder andere mögliche Erklärung?

GPS pos hold
geht prinzipiell, aber sehr schwammig, spät und indirekt. Er wird bei seinen Korrekturbewegungen immer größer und braucht dann schon einige Meter. entsprechen heftig sind dann auch die Steuerausschläge.
da die hauptsächlich in Längsrichtung sind: kann es sein, dass das deutlich verringerte Stab Pitch P sich hier auch auswirkt?
jedenfalls kann von auf der Stelle halten keine Rede sein.

habe einmal kurz loiter probiert, aber da kam es zu heftigen reaktionen, gleich wieder weggeschaltet.

Also insgesamt geht grundsätzlich alles, aber die beschriebenen “bugs” müssen natürlich noch weg…

Viele grüße Holger

Hallo Felix,
aktuell wurde mir ein update vom MP angeboten. gemacht - und jetzt wird alles angezeigt. gab auch kleine Änedrungen, z.B. bei extended tuning kann man jetzt direkt 4 Kanäle mit funktionen belegen.

war noch mal los. aber keine großartigen Änderungen.
bei Stabilize geht er immer noch zur Seite, obwohl ich ihn auf dem Tisch mit wasserwage ausgelevelt habe. nach dem hintrimmen werden die Trimmwerte (über save trim) weiterhin nicht gespeichert.

höhe halten auch nicht besser. ich dachte ja, ggf. stört der Rotorwind das Baro und habe den ganzen FC in Schaumstoff eingehüllt. brachte aber keine Besserung. ist auch unterschiedlich: manchmal fängt er sofort an, insgesamt hoch / runter zu schwingen / zittern, manchmal erst nach einigen Sekunden.

habe eine Änderung bei “altitude hold P” im extended tuning versucht (standard 1,0). bei geringerem Wert wurde es gefühlt heftiger, bei leicht erhöht keine spürbare verbesserung.

deshalb habe ich Pos hold nicht nochmal probiert (siehe vorigen Text).

Nun bist Du wieder dran…

Viel grüße Holger

Hallo Holger,

das mit dem Kompass kalibrieren würde ich nicht aufgeben. Es ist wichtig, dass Dein System erstmal ein grundsätzlich sauberes Setup hat und dann können wir ums um die weiteren Probleme – sollten sie dann noch da sein – kümmern. Ich gehe noch immer davon aus, dass Deine Kompass-Ausrichtung evtl. nicht stimmt. Dann kannst Du so lange versuchen zu kalibrieren, wie Du willst und es wird nicht funktionieren. Du könntest mir mal einen Log erstellen und dann schaue ich mir an, ob das mit der Ausrichtung stimmt. Aktiviere dazu einfach mal alle Kompasse, und drehe den Heli langsam um alle Achsen. In Nick und Roll musst Du natürlich nicht komplett herum drehen, sondern es reicht, wenn Du die Zelle ein Stück weit neigst, damit ich sehen kann, in welche Richtung die Magnetometer-Signale ausschlagen.

Das mit dem Wegdriften ist auf jeden Fall in den Griff zu bekommen. Vielleicht muss Deine Zelle einfach ein klein wenig schräg in der Luft hängen, damit der Heli auf der Stelle bleibt. Bei den Helis mit Heckrotor ist das sowieso der Fall. Bei Deinem könnten aber auch minimale Abweichungen im Einbauwinkel der Rotorwellen oder ähnliches dafür verantwortlich sein.

Es gibt einen Parameter (ATC_HOVR_ROL_TRM) mit dem man den Hängewinkel vorgeben kann, mit dem der Heckrotorschub kompensiert werden soll. Aber Achtung: Evtl. kommt das Wegdriften bei Dir auch durch ein unsauberes Attitude-Tracking zustande. Hast Du den I-Wert aktiviert? (Was hast Du für einen ILMI-Wert?) Vielleicht schickst Du mir auch einfach mal einen Flightlog. Daran müsste man erkennen können, ob ein schlechtes Attitude-Tracking oder einfach eine falsche Soll-Fluglage dafür verantwortlich sind. Wenn man weiß, was es ist, kann man beides ganz leicht beheben.

Woher Deine Schwingungen kommen, kann ich im Moment nicht genau sagen. Ich glaube es könnte auch am PID-Tuning liegen. Vielleicht kann man das in den Logs auch erkennen…

Viele Grüße

Felix

Servers by jDrones