Servers by jDrones

Precision landing using companion computer

Hi guys
I have tried squilter precision landing code with slight changes on camera section to make it work with an onboard camera on raspberry pi.
I aslo set PLND_ENABLED and PLND_TYPE parameters to 1.0 (enable,companion computer)
It seems the copter does not follow the landing pad when I switch to Land mode.
I’m sure the landing pad is detected by the raspberry pi but all the values under PL section in data flash log are zero.
Also M255:Landing_Target angle_x or M255:Landing_Target angle_y does not appear in QGroundcontrol.

I was able to successfuly implement precision landing in SITL.I tried to implement it on a real copter but the problem is I can not assure that it follows the landing pad. Do you have any idea?
There is no log data under PL section in dataflash log

Hello,

What version of copter code are you using ? And what are your parameters?

Hi @khancyr
I’m using Arducopter V3.7.0-dev.
I don’t have access to my parameters right now.
I’m going to upload them tomorrow.

Here is my parameters file:
param.param (17.7 KB)

@khancyr
Today I loaded the SITL parameters to the real copter
but nothing actually changed.
Everything looks good on the SITL but when it comes to the real situation it stops to function well.

Have you enable prec loiter?
This functionality is generally map to a switch http://ardupilot.org/copter/docs/precision-landing-with-irlock.html

It makes testing and checking plnd_land signal much easier

I have set an auxiliary channel to precloiter
and when I switch that channel nothing actually happens. There is no log under PL section.
I’m using RadioLink version of the pixhawk do you think it can be the source of the problem?

Can you read the prec_land message from mission planner (or QGC) when you do CTRL-F and look into mavlink inspector ?

Do you send the right message structure ?
Here is what it should look like:

1 Like

@ppoirier
Yes I do, Here is the screen shot of my mavlink inspector.


And still I do not get PL logs.

Humm… I dont have a test rig for debugging, maybe @fnoop could help

I guess you already saw my poster ?
https://github.com/patrickpoirier51/JeVois--Python-Tracking/blob/master/PRECISION_LANDING_SETUP.jpg

1 Like

Thanks a lot @ppoirier
Yes I already saw your poster and I could successfuly run prec land on SITL through your instructions.
I don’t know why LANDING_TARGET is created under Vehicle 255 every time I run the code.

1 Like

Generally it is because you initiate the system as a ‘‘standalone device’’ emitting a heartbeat.
This OK as it is not directly conflicting with the Flight Controller.

1 Like

Hi @ppoirier ,
Would you know if JeVois can detect an aruco marker from 25 meters altitude? How big do you think the marker should be? Would you recommend that camera for precision landing?
Best regards,
Sam.

Hello

Check on YouTube I made JeVois land from 20 meter with a 1 meter target

Yeah, I watched it! And also loved your poster :slight_smile:

Hi, I have the same issue on Vehicle 255, I can see ‘RANGEFINDER’, I can’t got the message from mavlink in RPi but I can see it on missionplanner .Could you give some help?



(0Hz is normal, Because I did not make it work when I take screen capture.)

Thanks a lot!

Servers by jDrones