Precision landing on copter 4.0.3 (IR-Lock)


does someone have experience with the ir lock precision landing on copter 4.0
i have al the parameters set that i can find on the forums but the percision landing doesn’t work

when i put it in precision loiter the copter doesn’t do anything an if i press land it just lands in the place it fly’s

the parameters i have set are

and for the precision loiter RC7_option = 39

I am also trying the same but didn’t get the results. Tried testing EST_TYPE = 0 as well as 1, but it didn’t work.
Have your problem been solved.
@ThomasSFL is the right person who can help us.
Let me know if your problem is solved.

Good Day @markb2309

Thank you for your message.

Please provide the .log file from your Precision Landing test flight.


Thanks for the response Thomas.
You can find the logs in this drive link

I have few queries mentioned below.

  1. Can i use rangefinder like Tera One.
  2. How to identify Prec Loiter is executed or not.
  3. Is Prec Landing and Loiter works in non GPS environment.
  4. Minimum height require to test the system.
  5. In which modes the prec land works like (guided, loiter, alt hold etc)

Thanks for your precious time.


Your log shows flight altitudes of only ~1 meter (rangefinder altitude). You will need to do Precision Landing test flights at ~10-15 meters.

Ok. I will test that and will come back with results.
Also, i have few doubts as mentioned above also. @ThomasSFL please address that also. That would be very helpful for executing different stuffs with IRLock.

Yes, GPS is required for the Precision Landing feature.

You can use a different rangefinder. However, the LW20 is the most robust against IR interference.

Hello all!

I’m working on implementing IRLock into my current drone and have ran into an issue. I have a Maxbotix I2C Sonar Rangefinder hooked up the my flight controller (Cube Black) with the IRLock Camera Sensor reading from a MarkOne Beacon. I am using a I2C splitter so that both the Camera and Rangefinder can interface with the FC. I am getting values from the rangefinder without issue, but am not seeing anything from the camera. If I arm, put into land mode, and examine logs, the health and target acquired are both zero. I haven’t messed with the settings on the PixyCam at all.

If anyone has suggestions, I’m all ears!

PixyCam version: 1.0.3

Arducopter 4.0.3

FC: Cube Black