PreArm: RC not found. PreArm: Rangefinder 1: No Data

New quad new problems.

coolyguy.param (20.3 KB)

FC is a Holybro KakuteH7 v1.3. Rx is an Anyleaf ELRS dual-radio Receiver. Rangefinder is on a Matek 3901-L0X. RC controller is a Radiomaster TX16S.

The radio and receiver can see each other. I get RSS values back from the receiver on the radio’s display screen.

But prearm says it can’t see the radio, and the radio calibration screen doesn’t show any green bars.

Connections are as per

Save for I don’t have a DJI air unit. Serial1 is instead being used for the 3901-L0X via a JST SH 6 pin connector.
Rx is wired per instructions

I believe I have everything wired correctly. I managed to get the GPS/compass working and each of the associated wires is black - no color coding to assist. I checked the wires before soldering and checked them again afterwards.
holybro-kakuteh7-coloured pinout

Also this radio works fine with a different Rx on a pixhawk 2.4.8, which is also ELRS, so I don’t think there’s a problem with the radio. I flashed the Rx’s firmware and it’s set to the same binding phrase as the radio.

I’m a little bit confused by the wiki page Holybro Kakute H7 V1 — Copter documentation. It says "The R6 pin, which by default is mapped to a timer input, can be used for all ArduPilot supported receiver protocols, except CRSF/ELRS and SRXL2 which require a true UART connection. However, FPort, when connected in this manner, will only provide RC without telemetry.

To allow CRSF and embedded telemetry available in Fport, CRSF, and SRXL2 receivers, the R6 pin can also be configured to be used as true UART RX pin for use with bi-directional systems by setting the BRD_ALT_CONFIG to “1” so it becomes the SERIAL6 port’s RX input pin.

So ELRS doesn’t work on serial6, unless you set BRD_ALT_CONFIG to “1”, which I have done. But it still doesn’t work. Could anyone please look at this parameter file and tell me what I missed?
coolyguy.param (20.3 KB)

Thank you

I posted a blog post explaining how to configure that board with CRSF including the connections and all the settings.

Well it is not that board but it does have very similar documentation wording

Thank you. I think I found the blog post you mentioned. How to methodically tune (almost) any multicopter using ArduCopter 4.4.x It looks like section 2.2 will be especially useful.


Edit: I still don’t have it. I copied/modified the parameters from the file “03_RC_HWconfig.param” but it still doesn’t see the RC.


I thought it might have been soldered backwards, or bridged, so I desoldered it and resoldered it. That didn’t work. I tried putting a happymodel dual ep1 in its place, thinking maybe my Rx was bad. That also didn’t work. I thought maybe serial6 doesn’t have DMA, so I tried putting the Rx on serial1. That didn’t work either.

Same error. RC not found. I tried a different Rx. I tried a different port. Nada on both.

And just to be certain I’m not going crazy I got out an FC from a different project and verified that it still connects to the RC. It still works fine.

Thank you for the blog post but it hasn’t helped me and I still don’t know what to do. I followed the instructions and it worked on a different build but not this one. I do not know what to try next.