PreArm:Rangefinder showing no data even after showing data

I’m trying to connect NRA24 to cube orange plus.
NRA24 working and showing data over status but PreArm still showing no data.

Are you using ArduCopter 4.4.0beta4?
You should.

I’m using copter v4.3.7 and and the copter is very large in size. Using a beta over a large size build I think it will be a very risky thing.

Then set log disarmed to one, and after 30 seconds set it back to zero, download the .bin log file, upload it to a cloud file sharing service and post a link to it here.

How sure are you that that range finder is supported in ArduCopter 4.3.7?

What’s the height between the NRA24 and ground? If its less than 0.5m, the rangefinder won’t give a valid reading. If you check the mavlink packets it’ll be reading 0 but the display on MP/QGC displays the last value. Try lifting the rangefinder above 0.5m and see if the error goes away. If you’re using it indoors, the multipathing will cause issues.
Our workaround was to disable pre-arm checks for rangefinder. Works fine once its up in the air, tested to ~160m

my problem solved manufacturer send me a another firmware which solved all problems

can you please upload the firmware to the online drive and share the link???